CVE-2024-47535 Denial of Service attack on windows app using Netty

Medium 5.5 Published Updated

An attacker can cause a denial of service in Windows applications using Netty by creating a large file that triggers an unsafe read, crashing the application.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2024-47535?

CVE-2024-47535 is a medium-severity denial of service vulnerability in Netty Netty, published on 12 Nov 2024. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. An unsafe reading of environment file could potentially cause a denial of service in Netty. When loaded on an Windows application, Netty attempts to load a file that does not exist. If an attacker creates such a large file, the Netty application crashes. This vulnerability is fixed in 4.1.115.

Weakness: CWE-400

Which versions are affected by CVE-2024-47535?

2 open source packages ship an affected version, including io.netty:netty-common. It affects 1 product.

PackageAffectedFixed in
io.netty:netty-common MavenAll versions4.1.115.Final
io.netty:netty-common MavenAll versions4.1.115.Final
Linux distribution packages (15)
netty-tcnative SUSE:Linux Enterprise Module for Development Tools 15 SP5All versions2.0.69-150200.3.22.1
netty-tcnative SUSE:Linux Enterprise Module for Development Tools 15 SP6All versions2.0.69-150200.3.22.1
jctools SUSE:Linux Enterprise Module for Package Hub 15 SP5All versions4.0.5-150200.3.9.1
netty SUSE:Linux Enterprise Module for Package Hub 15 SP5All versions4.1.115-150200.4.26.1
jctools SUSE:Linux Enterprise Module for Package Hub 15 SP6All versions4.0.5-150200.3.9.1
netty SUSE:Linux Enterprise Module for Package Hub 15 SP6All versions4.1.115-150200.4.26.1
netty SUSE:Manager Server Module 4.3All versions4.1.44.Final-150400.3.6.3
susemanager-sync-data SUSE:Manager Server Module 4.3All versions4.3.23-150400.3.41.3
jctools openSUSE:Leap 15.5All versions4.0.5-150200.3.9.1
netty openSUSE:Leap 15.5All versions4.1.115-150200.4.26.1
netty-tcnative openSUSE:Leap 15.5All versions2.0.69-150200.3.22.1
jctools openSUSE:Leap 15.6All versions4.0.5-150200.3.9.1
netty openSUSE:Leap 15.6All versions4.1.115-150200.4.26.1
netty-tcnative openSUSE:Leap 15.6All versions2.0.69-150200.3.22.1
netty openSUSE:TumbleweedAll versions4.1.115-1.1

Products include Netty Netty.

How do I fix CVE-2024-47535?

Upgrade io.netty:netty-common to 4.1.115.Final or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-47535 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47535 exists.

All Netty Netty vulnerabilities

Sources

Also known as CLEANSTART-2026-BY06273, CLEANSTART-2026-DV78787, CLEANSTART-2026-HT34208, CLEANSTART-2026-UI81727, CLEANSTART-2026-UT87465, ECHO-fbb6-be14-cc2d and 19 more.

Is CVE-2024-47535 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free