# CVE-2024-47554: Apache Commons IO: Possible denial of service attack on untrusted input to XmlStreamReader

> Attackers can cause excessive CPU consumption and denial of service by sending malicious input to the XmlStreamReader class in Apache Commons IO.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Oct 2024
- **Updated:** 31 Jan 2025
- **Also known as:** AZL-50019, AZL-50031, CLEANSTART-2026-FM94939, CLEANSTART-2026-PL91023, CLEANSTART-2026-QI10138, CLEANSTART-2026-UQ49290, CLSA-2025-1759795577, CLSA-2025-1764634061, CLSA-2026-1776126821, CLSA-2026-1778633126, CLSA-2026-1779670106, CLSA-2026-1784250510, CLSA-2026-1788757840, CLSA-2026-1789374817, CLSA-2026-1789374823, DEBIAN-CVE-2024-47554, ECHO-a183-8be8-b97e, GHSA-78wr-2p64-hpwj, MINI-2gfh-wqrj-phqm, MINI-c39w-54mc-mfr4, MINI-f5hj-4m92-wrv3, MINI-f6wp-5xgf-67vw, MINI-fm77-f42h-xxcg, MINI-h8v8-r7hq-xj5f, MINI-hj4j-pc9r-jf99, MINI-hmfx-r292-4j9h, MINI-jwc6-427g-56pc, MINI-qfhf-mffr-m5rj, MINI-rvp9-fq8c-3qjr, MINI-vg8j-ff7x-247f, MINI-vvq2-32w4-hgf9, MINI-x4gv-c39v-mm53, OESA-2024-2558, RHLW-2026-4aa7ebdfd0b8c810, RHLW-2026-a317ddba4af7590d, RHLW-2026-f8fc2683e717e6a2, ROOT-APP-MAVEN-CVE-2024-47554, SUSE-RU-2025:1150-1, SUSE-SU-2024:3596-1, UBUNTU-CVE-2024-47554, USN-8191-1, openSUSE-SU-2024:14387-1

## What is CVE-2024-47554?

CVE-2024-47554 is a medium-severity denial of service vulnerability in Netapp Active Iq Unified Manager, published on 3 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Uncontrolled Resource Consumption vulnerability in Apache Commons IO.

The org.apache.commons.io.input.XmlStreamReader class may excessively consume CPU resources when processing maliciously crafted input.

This issue affects Apache Commons IO: from 2.0 before 2.14.0.

Users are recommended to upgrade to version 2.14.0 or later, which fixes the issue.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-47554?

2 open source packages ship an affected version, including commons-io:commons-io. It affects 8 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `commons-io:commons-io` | Maven | From 2.0 | 2.14.0 |
| `commons-io:commons-io` | Maven | From 2.0 | 2.14.0 |
| `apache-commons-io` | SUSE:Enterprise Storage 7.1 | All versions | 2.18.0-150200.3.15.1 |
| `apache-commons-io` | SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 2.18.0-150200.3.15.1 |
| `apache-commons-io` | SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 2.18.0-150200.3.15.1 |
| `apache-commons-io` | SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 2.18.0-150200.3.15.1 |
| `apache-commons-io` | SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 2.18.0-150200.3.15.1 |
| `apache-commons-io` | SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 2.18.0-150200.3.15.1 |
| `apache-commons-io` | SUSE:Linux Enterprise Module for Basesystem 15 SP6 | All versions | 2.18.0-150200.3.15.1 |
| `apache-commons-io` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 2.17.0-11.3.1 |
| `apache-commons-io` | SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 2.18.0-150200.3.15.1 |
| `apache-commons-io` | SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 2.18.0-150200.3.15.1 |
| `apache-commons-io` | SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 2.18.0-150200.3.15.1 |
| `apache-commons-io` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 2.17.0-11.3.1 |
| `apache-commons-io` | SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 2.18.0-150200.3.15.1 |
| `apache-commons-io` | SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 2.18.0-150200.3.15.1 |
| `apache-commons-io` | SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 2.18.0-150200.3.15.1 |
| `apache-commons-io` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 2.17.0-11.3.1 |
| `apache-commons-io` | SUSE:Manager Proxy 4.3 | All versions | 2.18.0-150200.3.15.1 |
| `apache-commons-io` | SUSE:Manager Server 4.3 | All versions | 2.18.0-150200.3.15.1 |
| `apache-commons-io` | openSUSE:Leap 15.6 | All versions | 2.18.0-150200.3.15.1 |
| `apache-commons-io` | openSUSE:Tumbleweed | All versions | 2.17.0-2.1 |

Products: Apache Commons Io, Netapp Active Iq Unified Manager, Netapp Bluexp, Netapp E-Series Santricity Unified Manager, Netapp E-Series Santricity Web Services Proxy, Netapp Ontap Tools, Netapp Santricity Storage Plugin, Netapp Snapcenter.

## How do I fix CVE-2024-47554?

Upgrade commons-io:commons-io to 2.14.0 or later.

## Is CVE-2024-47554 being exploited?

There is no known exploitation of CVE-2024-47554 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2021-29425](https://insights.sbomify.com/CVE-2021-29425/): Possible limited path traversal vulnerabily in Apache Commons IO (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47554 and fix it if it is affected.

What it is: CVE-2024-47554 is a medium-severity denial of service vulnerability in Netapp Active Iq Unified Manager, published on 3 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-47554 in the wild and no public exploit code.

Affected packages and fixed versions:
- commons-io:commons-io (Maven): affected from 2.0; fixed in 2.14.0
- commons-io:commons-io (Maven): affected from 2.0; fixed in 2.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47554/ (Markdown: https://insights.sbomify.com/CVE-2024-47554/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47554
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47554
- OSV: https://osv.dev/vulnerability/CVE-2024-47554

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47554/
Summaries are generated and may contain mistakes; the official description above is the record.
