# CVE-2024-47561: Apache Avro Java SDK: Arbitrary Code Execution when reading Avro schema (Java SDK)

> Attackers can execute arbitrary code by providing malicious Avro schemas to applications using the vulnerable Java SDK.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Oct 2024
- **Updated:** 21 Oct 2024
- **Also known as:** CLEANSTART-2026-OR58043, CLEANSTART-2026-XQ43311, CLSA-2026-1774225177, CLSA-2026-1780966325, ECHO-eed7-929d-d078, GHSA-r7pg-v2c8-mfg3, JLSEC-2026-1374, MINI-2632-r6w9-3qph, MINI-2jjh-jw49-65jc, MINI-8wv9-x2jg-5wmg, MINI-mp8h-xqc5-8ww6, MINI-p7h5-x4gp-4359, MINI-pxqw-3cq8-fp8w, MINI-x2c7-qp7v-3gq6, OESA-2024-2227, RHSA-2024:7811, ROOT-APP-MAVEN-CVE-2024-47561

## What is CVE-2024-47561?

CVE-2024-47561 is a critical unsafe deserialization vulnerability in Netapp Active Iq Unified Manager, published on 3 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Schema parsing in the Java SDK of Apache Avro 1.11.3 and previous versions allows bad actors to execute arbitrary code.
Users are recommended to upgrade to version 1.11.4  or 1.12.0, which fix this issue.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2024-47561?

2 open source packages ship an affected version, including org.apache.avro:avro. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.avro:avro` | Maven | All versions | 1.11.4 |
| `org.apache.avro:avro` | Maven | All versions | 1.11.4 |
| `eap7-avro` | Red Hat:jboss_enterprise_application_platform:7.4::el7 | All versions | 0:1.11.4-1.redhat_00001.1.el7eap |
| `eap7-avro` | Red Hat:jboss_enterprise_application_platform:7.4::el8 | All versions | 0:1.11.4-1.redhat_00001.1.el8eap |
| `eap7-avro` | Red Hat:jboss_enterprise_application_platform:7.4::el9 | All versions | 0:1.11.4-1.redhat_00001.1.el9eap |

Products: Apache Avro, Netapp Active Iq Unified Manager, Netapp Brocade San Navigator.

## How do I fix CVE-2024-47561?

Upgrade org.apache.avro:avro to 1.11.4 or later.

## Is CVE-2024-47561 being exploited?

There is no known exploitation of CVE-2024-47561 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2023-39410](https://insights.sbomify.com/CVE-2023-39410/): Apache Avro Java SDK: Memory when deserializing untrusted data in Avro Java SDK (high 7.5)
- [CVE-2022-35724](https://insights.sbomify.com/CVE-2022-35724/): Denial of service while reading data in Avro Rust SDK (high 7.5)
- [CVE-2022-36124](https://insights.sbomify.com/CVE-2022-36124/): Memory overconsumption in Avro Rust SDK (high 7.5)
- [CVE-2022-36125](https://insights.sbomify.com/CVE-2022-36125/): Integer overflow when reading corrupted .avro file in Avro Rust SDK (high 7.5)
- [CVE-2021-43045](https://insights.sbomify.com/CVE-2021-43045/): Possible DOS vulnerabilities in C# Avro SDK (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47561 and fix it if it is affected.

What it is: CVE-2024-47561 is a critical unsafe deserialization vulnerability in Netapp Active Iq Unified Manager, published on 3 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-47561 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.avro:avro (Maven): affected all versions; fixed in 1.11.4
- org.apache.avro:avro (Maven): affected all versions; fixed in 1.11.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47561/ (Markdown: https://insights.sbomify.com/CVE-2024-47561/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47561
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47561
- OSV: https://osv.dev/vulnerability/CVE-2024-47561

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47561/
Summaries are generated and may contain mistakes; the official description above is the record.
