# CVE-2024-47611: XZ Utils on Microsoft Windows platform are vulnerable to argument injection

> Attackers can exploit Unicode filename handling in Windows command-line tools to inject arguments or traverse directories, potentially leading to code execution or data access.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 2 Oct 2024
- **Updated:** 21 Nov 2024
- **Also known as:** GHSA-m538-c5qw-3cg4

## What is CVE-2024-47611?

CVE-2024-47611 is a medium-severity command injection vulnerability in tukaani-project xz, published on 2 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XZ Utils provide a general-purpose data-compression library plus command-line tools. When built for native Windows (MinGW-w64 or MSVC), the command line tools from XZ Utils 5.6.2 and older have a command line argument injection vulnerability. If a command line contains Unicode characters (for example, filenames) that don't exist in the current legacy code page, the characters are converted to similar-looking characters with best-fit mapping. Some best-fit mappings result in ASCII characters that change the meaning of the command line, which can be exploited with malicious filenames to do argument injection or directory traversal attacks. This vulnerability is fixed in 5.6.3. Command line tools built for Cygwin or MSYS2 are unaffected. liblzma is unaffected.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command), CWE-176 (Improper Handling of Unicode Encoding)

## Which versions are affected by CVE-2024-47611?


## How do I fix CVE-2024-47611?

No fix has been published for CVE-2024-47611 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-47611 being exploited?

There is no known exploitation of CVE-2024-47611 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47611 and fix it if it is affected.

What it is: CVE-2024-47611 is a medium-severity command injection vulnerability in tukaani-project xz, published on 2 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-47611 in the wild and no public exploit code.

Affected product: tukaani-project xz. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47611/ (Markdown: https://insights.sbomify.com/CVE-2024-47611/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47611
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47611
- OSV: https://osv.dev/vulnerability/CVE-2024-47611

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47611/
Summaries are generated and may contain mistakes; the official description above is the record.
