{"answers":{"affected":"2 open source packages ship an affected version, including async-graphql.","exploited":"There is no known exploitation of CVE-2024-47614 in the wild and no public exploit code.","fix":"Upgrade async-graphql to 7.0.10 or later.","what":"CVE-2024-47614 is a high-severity denial of service vulnerability in async-graphql, published on 3 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-47614 and fix it if it is affected.\n\nWhat it is: CVE-2024-47614 is a high-severity denial of service vulnerability in async-graphql, published on 3 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-47614 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- async-graphql (crates.io): affected all versions; fixed in 7.0.10\n- async-graphql (crates.io): affected all versions; fixed in 7.0.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-47614/ (Markdown: https://insights.sbomify.com/CVE-2024-47614/index.md)","id":"CVE-2024-47614","markdown":"https://insights.sbomify.com/CVE-2024-47614/index.md","name":"CVE-2024-47614","record":{"aliases":["GHSA-5gc2-7c65-8fq8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust GraphQL library","requires_auth":"none","summary":"Attackers can cause service disruption and resource exhaustion by sending excessive directives to the async-graphql server.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"async-graphql is a GraphQL server library implemented in Rust. async-graphql before 7.0.10 does not limit the number of directives for a field. This can lead to Service Disruption, Resource Exhaustion, and User Experience Degradation. This vulnerability is fixed in 7.0.10.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"async-graphql vulnerable to Directive Overload","id":"CVE-2024-47614","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"GHSL-2024-117: GStreamer has an out-of-bounds write in Ogg demuxer","id":"CVE-2024-47615"},"packages":[{"ecosystem":"crates.io","fixed":["7.0.10"],"introduced":["0"],"last_affected":[],"package":"async-graphql","purl":null,"source":"GHSA-5gc2-7c65-8fq8"},{"ecosystem":"crates.io","fixed":["7.0.10"],"introduced":["0"],"last_affected":[],"package":"async-graphql","purl":"pkg:cargo/async-graphql","source":"GHSA-5gc2-7c65-8fq8"}],"prev":{"headline":"GHSL-2024-118: GStreamer has a null pointer dereference in gst_gdk_pixbuf_dec_flush","id":"CVE-2024-47613"},"products":["async-graphql"],"published":"2024-10-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-03","vendors":["async-graphql"]},"summary":"Attackers can cause service disruption and resource exhaustion by sending excessive directives to the async-graphql server.","url":"https://insights.sbomify.com/CVE-2024-47614/"}