# CVE-2024-47614: async-graphql vulnerable to Directive Overload

> Attackers can cause service disruption and resource exhaustion by sending excessive directives to the async-graphql server.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Oct 2024
- **Updated:** 3 Oct 2024
- **Also known as:** GHSA-5gc2-7c65-8fq8

## What is CVE-2024-47614?

CVE-2024-47614 is a high-severity denial of service vulnerability in async-graphql, published on 3 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

async-graphql is a GraphQL server library implemented in Rust. async-graphql before 7.0.10 does not limit the number of directives for a field. This can lead to Service Disruption, Resource Exhaustion, and User Experience Degradation. This vulnerability is fixed in 7.0.10.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-47614?

2 open source packages ship an affected version, including async-graphql.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `async-graphql` | crates.io | All versions | 7.0.10 |
| `async-graphql` | crates.io | All versions | 7.0.10 |

## How do I fix CVE-2024-47614?

Upgrade async-graphql to 7.0.10 or later.

## Is CVE-2024-47614 being exploited?

There is no known exploitation of CVE-2024-47614 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47614 and fix it if it is affected.

What it is: CVE-2024-47614 is a high-severity denial of service vulnerability in async-graphql, published on 3 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-47614 in the wild and no public exploit code.

Affected packages and fixed versions:
- async-graphql (crates.io): affected all versions; fixed in 7.0.10
- async-graphql (crates.io): affected all versions; fixed in 7.0.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47614/ (Markdown: https://insights.sbomify.com/CVE-2024-47614/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47614
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47614
- OSV: https://osv.dev/vulnerability/CVE-2024-47614

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47614/
Summaries are generated and may contain mistakes; the official description above is the record.
