{"answers":{"affected":"3 open source packages ship an affected version, including github.com/pomerium/pomerium.","exploited":"There is no known exploitation of CVE-2024-47616 in the wild and no public exploit code.","fix":"Upgrade github.com/pomerium/pomerium to 0.27.1 or later.","what":"CVE-2024-47616 is a medium-severity authentication bypass vulnerability in pomerium, published on 2 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-47616 and fix it if it is affected.\n\nWhat it is: CVE-2024-47616 is a medium-severity authentication bypass vulnerability in pomerium, published on 2 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-47616 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/pomerium/pomerium (Go): affected all versions; fixed in 0.27.1\n- github.com/pomerium/pomerium (Go): affected all versions; fixed in 0.27.1\n- github.com/pomerium/pomerium (Go): affected all versions; fixed in 0.27.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-47616/ (Markdown: https://insights.sbomify.com/CVE-2024-47616/index.md)","id":"CVE-2024-47616","markdown":"https://insights.sbomify.com/CVE-2024-47616/index.md","name":"CVE-2024-47616","record":{"aliases":["GHSA-r7rh-jww5-5fjr","GO-2024-3179"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Identity access proxy","requires_auth":"low_privilege","summary":"Attackers with valid service account tokens can bypass databroker API authorization to exfiltrate user data or modify Pomerium settings.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"Pomerium is an identity and context-aware access proxy. The Pomerium databroker service is responsible for managing all persistent Pomerium application state. Requests to the databroker service API are authorized by the presence of a JSON Web Token (JWT) signed by a key known by all Pomerium services in the same deployment. However, incomplete validation of this JWT meant that some service account access tokens would incorrectly be treated as valid for the purpose of databroker API authorization. Improper access to the databroker API could allow exfiltration of user info, spoofing of user sessions, or tampering with Pomerium routes, policies, and other settings. A Pomerium deployment is susceptible to this issue if all of the following conditions are met, you have issued a service account access token using Pomerium Zero or Pomerium Enterprise, the access token has an explicit expiration date in the future, and the core Pomerium databroker gRPC API is not otherwise secured by network access controls. This vulnerability is fixed in 0.27.1.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pomerium's service account access token may grant unintended access to databroker API","id":"CVE-2024-47616","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"Reflected XSS Vulnerability in Sulu Media Bundle","id":"CVE-2024-47617"},"packages":[{"ecosystem":"Go","fixed":["0.27.1"],"introduced":["0"],"last_affected":[],"package":"github.com/pomerium/pomerium","purl":null,"source":"GHSA-r7rh-jww5-5fjr"},{"ecosystem":"Go","fixed":["0.27.1"],"introduced":["0"],"last_affected":[],"package":"github.com/pomerium/pomerium","purl":"pkg:golang/github.com/pomerium/pomerium","source":"GHSA-r7rh-jww5-5fjr"},{"ecosystem":"Go","fixed":["0.27.1"],"introduced":["0"],"last_affected":[],"package":"github.com/pomerium/pomerium","purl":"pkg:golang/github.com/pomerium/pomerium","source":"GO-2024-3179"}],"prev":{"headline":"GHSL-2024-117: GStreamer has an out-of-bounds write in Ogg demuxer","id":"CVE-2024-47615"},"products":["pomerium"],"published":"2024-10-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-03","vendors":["pomerium"]},"summary":"Attackers with valid service account tokens can bypass databroker API authorization to exfiltrate user data or modify Pomerium settings.","url":"https://insights.sbomify.com/CVE-2024-47616/"}