# CVE-2024-47616: Pomerium's service account access token may grant unintended access to databroker API

> Attackers with valid service account tokens can bypass databroker API authorization to exfiltrate user data or modify Pomerium settings.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Oct 2024
- **Updated:** 3 Oct 2024
- **Also known as:** GHSA-r7rh-jww5-5fjr, GO-2024-3179

## What is CVE-2024-47616?

CVE-2024-47616 is a medium-severity authentication bypass vulnerability in pomerium, published on 2 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Pomerium is an identity and context-aware access proxy. The Pomerium databroker service is responsible for managing all persistent Pomerium application state. Requests to the databroker service API are authorized by the presence of a JSON Web Token (JWT) signed by a key known by all Pomerium services in the same deployment. However, incomplete validation of this JWT meant that some service account access tokens would incorrectly be treated as valid for the purpose of databroker API authorization. Improper access to the databroker API could allow exfiltration of user info, spoofing of user sessions, or tampering with Pomerium routes, policies, and other settings. A Pomerium deployment is susceptible to this issue if all of the following conditions are met, you have issued a service account access token using Pomerium Zero or Pomerium Enterprise, the access token has an explicit expiration date in the future, and the core Pomerium databroker gRPC API is not otherwise secured by network access controls. This vulnerability is fixed in 0.27.1.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-47616?

3 open source packages ship an affected version, including github.com/pomerium/pomerium.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/pomerium/pomerium` | Go | All versions | 0.27.1 |
| `github.com/pomerium/pomerium` | Go | All versions | 0.27.1 |
| `github.com/pomerium/pomerium` | Go | All versions | 0.27.1 |

## How do I fix CVE-2024-47616?

Upgrade github.com/pomerium/pomerium to 0.27.1 or later.

## Is CVE-2024-47616 being exploited?

There is no known exploitation of CVE-2024-47616 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47616 and fix it if it is affected.

What it is: CVE-2024-47616 is a medium-severity authentication bypass vulnerability in pomerium, published on 2 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-47616 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/pomerium/pomerium (Go): affected all versions; fixed in 0.27.1
- github.com/pomerium/pomerium (Go): affected all versions; fixed in 0.27.1
- github.com/pomerium/pomerium (Go): affected all versions; fixed in 0.27.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47616/ (Markdown: https://insights.sbomify.com/CVE-2024-47616/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47616
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47616
- OSV: https://osv.dev/vulnerability/CVE-2024-47616

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47616/
Summaries are generated and may contain mistakes; the official description above is the record.
