# CVE-2024-47821: pyLoad vulnerable to remote code execution by download to /.pyload/scripts using /flashgot API

> An attacker with settings access can execute arbitrary code by downloading scripts to the scripts folder via the flashgot API.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2024
- **Updated:** 28 Oct 2024
- **Also known as:** GHSA-w7hq-f2pj-c53g, PYSEC-2024-302

## What is CVE-2024-47821?

CVE-2024-47821 is a critical code injection vulnerability in pyload, published on 25 Oct 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

pyLoad is a free and open-source Download Manager. The folder `/.pyload/scripts` has scripts which are run when certain actions are completed, for e.g. a download is finished. By downloading a executable file to a folder in /scripts and performing the respective action, remote code execution can be achieved in versions prior to 0.5.0b3.dev87. A file can be downloaded to such a folder by changing the download folder to a folder in `/scripts` path and using the `/flashgot` API to download the file. This vulnerability allows an attacker with access to change the settings on a pyload server to execute arbitrary code and completely compromise the system. Version 0.5.0b3.dev87 fixes this issue.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2024-47821?

3 open source packages ship an affected version, including pyload-ng. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyload-ng` | PyPI | All versions to 0.5.0 | None |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev87 |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev87 |

Products: Pyload Pyload.

## How do I fix CVE-2024-47821?

Upgrade pyload-ng to 0.5.0b3.dev87 or later.

## Is CVE-2024-47821 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47821 exists.

## Other vulnerabilities in pyload

- [CVE-2023-0297](https://insights.sbomify.com/CVE-2023-0297/): Code Injection in pyload/pyload (critical 9.8)
- [CVE-2026-33992](https://insights.sbomify.com/CVE-2026-33992/): pyLoad: Server-Side Request Forgery via Download Link Submission Enables Cloud Metadata Exfiltration (critical 9.3)
- [CVE-2024-32880](https://insights.sbomify.com/CVE-2024-32880/): pyLoad allows upload to arbitrary folder lead to RCE (critical 9.1)
- [CVE-2026-41133](https://insights.sbomify.com/CVE-2026-41133/): pyLoad has Stale Session Privilege After Role/Permission Change (Privilege Revocation Bypass) (high 8.8)
- [CVE-2023-47890](https://insights.sbomify.com/CVE-2023-47890/): Download to arbitrary folder can lead to RCE (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47821 and fix it if it is affected.

What it is: CVE-2024-47821 is a critical code injection vulnerability in pyload, published on 25 Oct 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47821 exists.

Affected packages and fixed versions:
- pyload-ng (PyPI): affected all versions up to 0.5.0; no fix listed
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev87
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev87

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47821/ (Markdown: https://insights.sbomify.com/CVE-2024-47821/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47821
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47821
- OSV: https://osv.dev/vulnerability/CVE-2024-47821

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47821/
Summaries are generated and may contain mistakes; the official description above is the record.
