# CVE-2024-47825: CIDR deny policies may not take effect when a more narrow CIDR allow is present

> Attackers can bypass CIDR deny policies in Cilium when specific allow rules are configured, potentially accessing restricted network resources.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Oct 2024
- **Updated:** 21 Oct 2024
- **Also known as:** BIT-cilium-2024-47825, BIT-cilium-operator-2024-47825, BIT-hubble-relay-2024-47825, GHSA-3wwx-63fv-pfq6, GO-2024-3208

## What is CVE-2024-47825?

CVE-2024-47825 is a medium-severity vulnerability in cilium, published on 21 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. Starting in version 1.14.0 and prior to versions 1.14.16 and 1.15.10, a policy rule denying a prefix that is broader than `/32` may be ignored if there is a policy rule referencing a more narrow prefix (`CIDRSet` or `toFQDN`) and this narrower policy rule specifies either `enableDefaultDeny: false` or `- toEntities: all`. Note that a rule specifying `toEntities: world` or `toEntities: 0.0.0.0/0` is insufficient, it must be to entity `all`.This issue has been patched in Cilium v1.14.16 and v1.15.10. As this issue only affects policies using `enableDefaultDeny: false` or that set `toEntities` to `all`, some workarounds are available. For users with policies using `enableDefaultDeny: false`, remove this configuration option and explicitly define any allow rules required. For users with egress policies that explicitly specify `toEntities: all`, use `toEntities: world`.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2024-47825?

8 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cilium/cilium` | Go | From 1.14.0 | 1.14.16, 1.15.10 |
| `github.com/cilium/cilium` | Go | From 1.14.0 | 1.14.16 |
| `github.com/cilium/cilium` | Go | From 1.14.0 | 1.14.16 |
| `github.com/cilium/cilium` | Go | From 1.15.0 | 1.15.10 |
| `github.com/cilium/cilium` | Go | From 1.15.0 | 1.15.10 |
| `cilium` | Bitnami | From 1.15.4 | 1.16.0 |
| `cilium-operator` | Bitnami | From 1.15.4 | 1.16.0 |
| `hubble-relay` | Bitnami | From 1.14.0 | 1.16.0 |

Products: Cilium Cilium.

## How do I fix CVE-2024-47825?

Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.14.16 or 1.15.10.

## Is CVE-2024-47825 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47825 exists.

## Other vulnerabilities in cilium

- [CVE-2026-49445](https://insights.sbomify.com/CVE-2026-49445/): Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access (critical 9.2)
- [CVE-2022-29178](https://insights.sbomify.com/CVE-2022-29178/): Incorrect Default Permissions in Cilium (high 8.8)
- [CVE-2024-28860](https://insights.sbomify.com/CVE-2024-28860/): Insecure IPsec transport encryption in Cilium (high 8.0)
- [CVE-2026-41520](https://insights.sbomify.com/CVE-2026-41520/): Cillium exposes sensitive information included in the cilium-bugtool debug archive (high 7.9)
- [CVE-2024-37307](https://insights.sbomify.com/CVE-2024-37307/): Cilium leaks sensitive information in cilium-bugtool (high 7.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47825 and fix it if it is affected.

What it is: CVE-2024-47825 is a medium-severity vulnerability in cilium, published on 21 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47825 exists.

Affected packages and fixed versions:
- github.com/cilium/cilium (Go): affected from 1.14.0; fixed in 1.14.16, 1.15.10
- github.com/cilium/cilium (Go): affected from 1.14.0; fixed in 1.14.16
- github.com/cilium/cilium (Go): affected from 1.14.0; fixed in 1.14.16
- github.com/cilium/cilium (Go): affected from 1.15.0; fixed in 1.15.10
- github.com/cilium/cilium (Go): affected from 1.15.0; fixed in 1.15.10
- cilium (Bitnami): affected from 1.15.4; fixed in 1.16.0
- cilium-operator (Bitnami): affected from 1.15.4; fixed in 1.16.0
- hubble-relay (Bitnami): affected from 1.14.0; fixed in 1.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47825/ (Markdown: https://insights.sbomify.com/CVE-2024-47825/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47825
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47825
- OSV: https://osv.dev/vulnerability/CVE-2024-47825

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47825/
Summaries are generated and may contain mistakes; the official description above is the record.
