# CVE-2024-47833: Session Cookie without Secure and HTTPOnly flags in taipy

> Attackers can intercept session cookies due to missing Secure and HTTPOnly flags, potentially leading to session hijacking in Taipy applications.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Oct 2024
- **Updated:** 9 Oct 2024
- **Also known as:** GHSA-r3jq-4r5c-j9hp, PYSEC-2024-168

## What is CVE-2024-47833?

CVE-2024-47833 is a medium-severity vulnerability in Avaiga taipy, published on 9 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Taipy is an open-source Python library for easy, end-to-end application development for data scientists and machine learning engineers. In affected versions session cookies are served without Secure and HTTPOnly flags. This issue has been addressed in release version 4.0.0 and all users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information), CWE-614 (Sensitive Cookie in HTTPS Session Without 'Secure' Attribute), CWE-732 (Incorrect Permission Assignment for Critical Resource), CWE-1004 (Sensitive Cookie Without 'HttpOnly' Flag)

## Which versions are affected by CVE-2024-47833?

3 open source packages ship an affected version, including taipy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `taipy` | PyPI | All versions | 4.0.0 |
| `taipy` | PyPI | All versions | 4.0.0 |
| `taipy` | PyPI | All versions | 4.0.0 |

Products: Avaiga Taipy.

## How do I fix CVE-2024-47833?

Upgrade taipy to 4.0.0 or later.

## Is CVE-2024-47833 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47833 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47833 and fix it if it is affected.

What it is: CVE-2024-47833 is a medium-severity vulnerability in Avaiga taipy, published on 9 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47833 exists.

Affected packages and fixed versions:
- taipy (PyPI): affected all versions; fixed in 4.0.0
- taipy (PyPI): affected all versions; fixed in 4.0.0
- taipy (PyPI): affected all versions; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47833/ (Markdown: https://insights.sbomify.com/CVE-2024-47833/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47833
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47833
- OSV: https://osv.dev/vulnerability/CVE-2024-47833

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47833/
Summaries are generated and may contain mistakes; the official description above is the record.
