CVE-2024-4784 Authentication Bypass by Primary Weakness in GitLab

Medium 4.2 Published Updated

Attackers can bypass password re-entry requirements to approve policies in GitLab EE, undermining security controls.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-4784?

CVE-2024-4784 is a medium-severity authentication bypass vulnerability in Gitlab Gitlab, published on 8 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue was discovered in GitLab EE starting from version 16.7 before 17.0.6, version 17.1 before 17.1.4 and 17.2 before 17.2.2 that allowed bypassing the password re-entry requirement to approve a policy.

Weakness: CWE-287, CWE-305

Which versions are affected by CVE-2024-4784?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.7.017.0.6, 17.1.4, 17.2.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-4784?

Upgrade gitlab to a fixed version for your release line: 17.0.6, 17.1.4 or 17.2.2.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2024-4784 being exploited?

There is no known exploitation of CVE-2024-4784 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-4784, GHSA-662c-cj8q-qc4g, UBUNTU-CVE-2024-4784.

Is CVE-2024-4784 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free