# CVE-2024-47847: Various XSSes found in Cargo

> Cross-site scripting vulnerability in the MediaWiki Cargo extension allows attackers to inject malicious scripts into web pages viewed by other users.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2024
- **Updated:** 7 Oct 2024
- **Also known as:** GHSA-jqvm-9xm2-gc38

## What is CVE-2024-47847?

CVE-2024-47847 is a medium-severity cross-site scripting vulnerability in The Wikimedia Foundation Mediawiki - Cargo, published on 5 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in The Wikimedia Foundation Mediawiki - Cargo allows Cross-Site Scripting (XSS).This issue affects Mediawiki - Cargo: from 3.6.X before 3.6.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-47847?

2 open source packages ship an affected version, including mediawiki/cargo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki/cargo` | Packagist | All versions | 3.6.1 |
| `mediawiki/cargo` | Packagist | All versions | 3.6.1 |

Products: Mediawiki Cargo.

## How do I fix CVE-2024-47847?

Upgrade mediawiki/cargo to 3.6.1 or later.

## Is CVE-2024-47847 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47847 exists.

## Other vulnerabilities in The Wikimedia Foundation Mediawiki - Cargo

- [CVE-2024-47849](https://insights.sbomify.com/CVE-2024-47849/): Backticks can allow the usage of not-allowed SQL functions (high 8.8)
- [CVE-2026-14363](https://insights.sbomify.com/CVE-2026-14363/): Cargo Extension: SQLi in Special:Drilldown (medium 6.9)
- [CVE-2026-58519](https://insights.sbomify.com/CVE-2026-58519/): Stored XSS through Cargo's map format (medium 6.9)
- [CVE-2026-58521](https://insights.sbomify.com/CVE-2026-58521/): SQLi in Cargo extension via year range filter (medium 6.9)
- [CVE-2024-47846](https://insights.sbomify.com/CVE-2024-47846/): Special:DeleteCargoTable and Special:SwitchCargoTable have no CSRF protection (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47847 and fix it if it is affected.

What it is: CVE-2024-47847 is a medium-severity cross-site scripting vulnerability in The Wikimedia Foundation Mediawiki - Cargo, published on 5 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47847 exists.

Affected packages and fixed versions:
- mediawiki/cargo (Packagist): affected all versions; fixed in 3.6.1
- mediawiki/cargo (Packagist): affected all versions; fixed in 3.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47847/ (Markdown: https://insights.sbomify.com/CVE-2024-47847/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47847
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47847
- OSV: https://osv.dev/vulnerability/CVE-2024-47847

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47847/
Summaries are generated and may contain mistakes; the official description above is the record.
