{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47850 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2024-47850 is a high-severity denial of service vulnerability in n/a, published on 4 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-47850 and fix it if it is affected.\n\nWhat it is: CVE-2024-47850 is a high-severity denial of service vulnerability in n/a, published on 4 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47850 exists.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-47850/ (Markdown: https://insights.sbomify.com/CVE-2024-47850/index.md)","id":"CVE-2024-47850","markdown":"https://insights.sbomify.com/CVE-2024-47850/index.md","name":"CVE-2024-47850","record":{"aliases":["AZL-53837","DEBIAN-CVE-2024-47850","GHSA-phc2-g348-384g","GHSA-rq86-c7g6-r2h8","SUSE-SU-2024:3756-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"CUPS printing service","requires_auth":"none","summary":"Attackers can trigger DDoS amplification by sending a single UDP packet, causing CUPS to send HTTP POST requests to arbitrary destinations.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"CUPS cups-browsed before 2.5b1 will send an HTTP POST request to an arbitrary destination and port in response to a single IPP UDP packet requesting a printer to be added, a different vulnerability than CVE-2024-47176. (The request is meant to probe the new printer but can be used to create DDoS amplification attacks.)","ecosystems":["SUSE:Linux Enterprise Server 12 SP5-LTSS","SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2024-47850","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2024-47853"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 12 SP5-LTSS","fixed":["1.0.58-19.32.1"],"introduced":["0"],"last_affected":[],"package":"cups-filters","purl":"pkg:rpm/suse/cups-filters\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP5-LTSS","source":"SUSE-SU-2024:3756-1"},{"ecosystem":"SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","fixed":["1.0.58-19.32.1"],"introduced":["0"],"last_affected":[],"package":"cups-filters","purl":"pkg:rpm/suse/cups-filters\u0026distro=SUSE%20Linux%20Enterprise%20Server%20LTSS%20Extended%20Security%2012%20SP5","source":"SUSE-SU-2024:3756-1"}],"prev":{"headline":"Backticks can allow the usage of not-allowed SQL functions","id":"CVE-2024-47849"},"products":["n/a"],"published":"2024-10-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-11","vendors":["n/a"]},"summary":"Attackers can trigger DDoS amplification by sending a single UDP packet, causing CUPS to send HTTP POST requests to arbitrary destinations.","url":"https://insights.sbomify.com/CVE-2024-47850/"}