{"answers":{"affected":"4 open source packages ship an affected version, including net.sf.json-lib:json-lib and org.kordamp.json:json-lib-core.","exploited":"There is no known exploitation of CVE-2024-47855 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-47855 is a medium-severity denial of service vulnerability in n/a, published on 4 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-47855 and fix it if it is affected.\n\nWhat it is: CVE-2024-47855 is a medium-severity denial of service vulnerability in n/a, published on 4 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-47855 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- net.sf.json-lib:json-lib (Maven): affected all versions up to 2.4; no fix listed\n- net.sf.json-lib:json-lib (Maven): affected all versions up to 2.4; no fix listed\n- org.kordamp.json:json-lib-core (Maven): affected all versions; fixed in 3.1.0\n- org.kordamp.json:json-lib-core (Maven): affected all versions; fixed in 3.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-47855/ (Markdown: https://insights.sbomify.com/CVE-2024-47855/index.md)","id":"CVE-2024-47855","markdown":"https://insights.sbomify.com/CVE-2024-47855/index.md","name":"CVE-2024-47855","record":{"aliases":["DEBIAN-CVE-2024-47855","GHSA-wwcp-26wc-3fxm","OESA-2024-2228","SUSE-SU-2024:3543-1","UBUNTU-CVE-2024-47855"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Java JSON library","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using JSON-lib by providing an unbalanced comment string in JSON input.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[],"description":"util/JSONTokener.java in JSON-lib before 3.1.0 mishandles an unbalanced comment string.","ecosystems":["Maven","openSUSE:Leap 15.5","openSUSE:Leap 15.6"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"JSON-lib mishandles an unbalanced comment string","id":"CVE-2024-47855","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":6,"n_references":2,"next":{"headline":"Path traversal in n/a","id":"CVE-2024-47856"},"packages":[{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":["2.4"],"package":"net.sf.json-lib:json-lib","purl":null,"source":"GHSA-wwcp-26wc-3fxm"},{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":["2.4"],"package":"net.sf.json-lib:json-lib","purl":"pkg:maven/net.sf.json-lib/json-lib","source":"GHSA-wwcp-26wc-3fxm"},{"ecosystem":"Maven","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"org.kordamp.json:json-lib-core","purl":null,"source":"GHSA-wwcp-26wc-3fxm"},{"ecosystem":"Maven","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"org.kordamp.json:json-lib-core","purl":"pkg:maven/org.kordamp.json/json-lib-core","source":"GHSA-wwcp-26wc-3fxm"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["2.4-150200.3.7.1"],"introduced":["0"],"last_affected":[],"package":"json-lib","purl":"pkg:rpm/opensuse/json-lib\u0026distro=openSUSE%20Leap%2015.5","source":"SUSE-SU-2024:3543-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["2.4-150200.3.7.1"],"introduced":["0"],"last_affected":[],"package":"json-lib","purl":"pkg:rpm/opensuse/json-lib\u0026distro=openSUSE%20Leap%2015.6","source":"SUSE-SU-2024:3543-1"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2024-47854"},"products":["n/a"],"published":"2024-10-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-07","vendors":["n/a"]},"summary":"An attacker can cause a denial of service in applications using JSON-lib by providing an unbalanced comment string in JSON input.","url":"https://insights.sbomify.com/CVE-2024-47855/"}