# CVE-2024-47867: Lack of integrity check on the downloaded FRP client in Gradio

> Attackers can execute malicious code by compromising the FRP client download if the sharing feature is used, as Gradio lacks integrity checks.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2024
- **Updated:** 11 Oct 2024
- **Also known as:** GHSA-8c87-gvhj-xm8m, PYSEC-2024-216

## What is CVE-2024-47867?

CVE-2024-47867 is a low-severity vulnerability in Gradio Project Gradio, published on 10 Oct 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Gradio is an open-source Python package designed for quick prototyping. This vulnerability is a **lack of integrity check** on the downloaded FRP client, which could potentially allow attackers to introduce malicious code. If an attacker gains access to the remote URL from which the FRP client is downloaded, they could modify the binary without detection, as the Gradio server does not verify the file's checksum or signature.  Any users utilizing the Gradio server's sharing mechanism that downloads the FRP client could be affected by this vulnerability, especially those relying on the executable binary for secure data tunneling. There is no direct workaround for this issue without upgrading. However, users can manually validate the integrity of the downloaded FRP client by implementing checksum or signature verification in their own environment to ensure the binary hasn't been tampered with.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2024-47867?

3 open source packages ship an affected version, including gradio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gradio` | PyPI | All versions | 5.0.0 |
| `gradio` | PyPI | All versions | 5.0.0 |
| `gradio` | PyPI | All versions | 5.0.0 |

Products: Gradio Project Gradio.

## How do I fix CVE-2024-47867?

Upgrade gradio to 5.0.0 or later.

## Is CVE-2024-47867 being exploited?

There is no known exploitation of CVE-2024-47867 in the wild and no public exploit code.

## Other vulnerabilities in Gradio Project Gradio

- [CVE-2024-39236](https://insights.sbomify.com/CVE-2024-39236/): Withdrawn Advisory: Gradio was discovered to contain a code injection vulnerability via the component /gradio/component_meta.py (critical 9.8)
- [CVE-2023-6572](https://insights.sbomify.com/CVE-2023-6572/): Command Injection in gradio-app/gradio (critical 9.6)
- [CVE-2022-24770](https://insights.sbomify.com/CVE-2022-24770/): Improper Neutralization of Formula Elements in a CSV File in Gradio Flagging (high 8.8)
- [CVE-2026-49119](https://insights.sbomify.com/CVE-2026-49119/): Gradio < 6.16.0 Path Traversal via FileExplorer.preprocess() (high 8.7)
- [CVE-2025-23042](https://insights.sbomify.com/CVE-2025-23042/): Gradio Blocked Path ACL Bypass Vulnerability (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47867 and fix it if it is affected.

What it is: CVE-2024-47867 is a low-severity vulnerability in Gradio Project Gradio, published on 10 Oct 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-47867 in the wild and no public exploit code.

Affected packages and fixed versions:
- gradio (PyPI): affected all versions; fixed in 5.0.0
- gradio (PyPI): affected all versions; fixed in 5.0.0
- gradio (PyPI): affected all versions; fixed in 5.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47867/ (Markdown: https://insights.sbomify.com/CVE-2024-47867/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47867
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47867
- OSV: https://osv.dev/vulnerability/CVE-2024-47867

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47867/
Summaries are generated and may contain mistakes; the official description above is the record.
