# CVE-2024-47869: Non-constant-time comparison when comparing hashes in Gradio

> Timing attack in Gradio allows attackers to bypass authentication and access the analytics dashboard by inferring hashes via response time analysis.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2024
- **Updated:** 11 Oct 2024
- **Also known as:** GHSA-j757-pf57-f8r4, PYSEC-2024-199

## What is CVE-2024-47869?

CVE-2024-47869 is a low-severity vulnerability in Gradio Project Gradio, published on 10 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Gradio is an open-source Python package designed for quick prototyping. This vulnerability involves a **timing attack** in the way Gradio compares hashes for the `analytics_dashboard` function. Since the comparison is not done in constant time, an attacker could exploit this by measuring the response time of different requests to infer the correct hash byte-by-byte. This can lead to unauthorized access to the analytics dashboard, especially if the attacker can repeatedly query the system with different keys. Users are advised to upgrade to `gradio>4.44` to mitigate this issue. To mitigate the risk before applying the patch, developers can manually patch the `analytics_dashboard` dashboard to use a **constant-time comparison** function for comparing sensitive values, such as hashes. Alternatively, access to the analytics dashboard can be disabled.

Weakness: CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2024-47869?

3 open source packages ship an affected version, including gradio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gradio` | PyPI | All versions | 4.44.0 |
| `gradio` | PyPI | All versions | 4.44.0 |
| `gradio` | PyPI | All versions | 4.44.0 |

Products: Gradio Project Gradio.

## How do I fix CVE-2024-47869?

Upgrade gradio to 4.44.0 or later.

## Is CVE-2024-47869 being exploited?

There is no known exploitation of CVE-2024-47869 in the wild and no public exploit code.

## Other vulnerabilities in Gradio Project Gradio

- [CVE-2024-39236](https://insights.sbomify.com/CVE-2024-39236/): Withdrawn Advisory: Gradio was discovered to contain a code injection vulnerability via the component /gradio/component_meta.py (critical 9.8)
- [CVE-2023-6572](https://insights.sbomify.com/CVE-2023-6572/): Command Injection in gradio-app/gradio (critical 9.6)
- [CVE-2022-24770](https://insights.sbomify.com/CVE-2022-24770/): Improper Neutralization of Formula Elements in a CSV File in Gradio Flagging (high 8.8)
- [CVE-2026-49119](https://insights.sbomify.com/CVE-2026-49119/): Gradio < 6.16.0 Path Traversal via FileExplorer.preprocess() (high 8.7)
- [CVE-2025-23042](https://insights.sbomify.com/CVE-2025-23042/): Gradio Blocked Path ACL Bypass Vulnerability (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47869 and fix it if it is affected.

What it is: CVE-2024-47869 is a low-severity vulnerability in Gradio Project Gradio, published on 10 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-47869 in the wild and no public exploit code.

Affected packages and fixed versions:
- gradio (PyPI): affected all versions; fixed in 4.44.0
- gradio (PyPI): affected all versions; fixed in 4.44.0
- gradio (PyPI): affected all versions; fixed in 4.44.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47869/ (Markdown: https://insights.sbomify.com/CVE-2024-47869/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47869
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47869
- OSV: https://osv.dev/vulnerability/CVE-2024-47869

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47869/
Summaries are generated and may contain mistakes; the official description above is the record.
