# CVE-2024-47872: Cross-site Scripting on Gradio server via upload of HTML files, JS files, or SVG files

> Authenticated users can upload malicious HTML, JS, or SVG files to Gradio servers, leading to XSS attacks against other users viewing the files.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2024
- **Updated:** 11 Oct 2024
- **Also known as:** GHSA-gvv6-33j7-884g, PYSEC-2024-220

## What is CVE-2024-47872?

CVE-2024-47872 is a medium-severity cross-site scripting vulnerability in Gradio Project Gradio, published on 10 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gradio is an open-source Python package designed for quick prototyping. This vulnerability involves **Cross-Site Scripting (XSS)** on any Gradio server that allows file uploads. Authenticated users can upload files such as HTML, JavaScript, or SVG files containing malicious scripts. When other users download or view these files, the scripts will execute in their browser, allowing attackers to perform unauthorized actions or steal sensitive information from their sessions. This impacts any Gradio server that allows file uploads, particularly those using components that process or display user-uploaded files. Users are advised to upgrade to `gradio>=5` to address this issue. As a workaround, users can restrict the types of files that can be uploaded to the Gradio server by limiting uploads to non-executable file types such as images or text. Additionally, developers can implement server-side validation to sanitize uploaded files, ensuring that HTML, JavaScript, and SVG files are properly handled or rejected before being stored or displayed to users.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-47872?

3 open source packages ship an affected version, including gradio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gradio` | PyPI | All versions | 5.0.0 |
| `gradio` | PyPI | All versions | 5.0.0 |
| `gradio` | PyPI | All versions | 5.0.0 |

Products: Gradio Project Gradio.

## How do I fix CVE-2024-47872?

Upgrade gradio to 5.0.0 or later.

## Is CVE-2024-47872 being exploited?

There is no known exploitation of CVE-2024-47872 in the wild and no public exploit code.

## Other vulnerabilities in Gradio Project Gradio

- [CVE-2024-39236](https://insights.sbomify.com/CVE-2024-39236/): Withdrawn Advisory: Gradio was discovered to contain a code injection vulnerability via the component /gradio/component_meta.py (critical 9.8)
- [CVE-2023-6572](https://insights.sbomify.com/CVE-2023-6572/): Command Injection in gradio-app/gradio (critical 9.6)
- [CVE-2022-24770](https://insights.sbomify.com/CVE-2022-24770/): Improper Neutralization of Formula Elements in a CSV File in Gradio Flagging (high 8.8)
- [CVE-2026-49119](https://insights.sbomify.com/CVE-2026-49119/): Gradio < 6.16.0 Path Traversal via FileExplorer.preprocess() (high 8.7)
- [CVE-2025-23042](https://insights.sbomify.com/CVE-2025-23042/): Gradio Blocked Path ACL Bypass Vulnerability (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47872 and fix it if it is affected.

What it is: CVE-2024-47872 is a medium-severity cross-site scripting vulnerability in Gradio Project Gradio, published on 10 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-47872 in the wild and no public exploit code.

Affected packages and fixed versions:
- gradio (PyPI): affected all versions; fixed in 5.0.0
- gradio (PyPI): affected all versions; fixed in 5.0.0
- gradio (PyPI): affected all versions; fixed in 5.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47872/ (Markdown: https://insights.sbomify.com/CVE-2024-47872/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47872
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47872
- OSV: https://osv.dev/vulnerability/CVE-2024-47872

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47872/
Summaries are generated and may contain mistakes; the official description above is the record.
