CVE-2024-47873 PhpSpreadsheet XmlScanner bypass leads to XXE
Attackers can bypass XML sanitization in PhpSpreadsheet to perform XML External Entity attacks, potentially reading sensitive data or executing code.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-47873?
CVE-2024-47873 is a high-severity vulnerability in PHPOffice PhpSpreadsheet, published on 18 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. The XmlScanner class has a scan method which should prevent XXE attacks. However, prior to versions 1.9.4, 2.1.3, 2.3.2, and 3.4.0, the regexes used in the `scan` method and the findCharSet method can be bypassed by using UCS-4 and encoding guessing. An attacker can bypass the sanitizer and achieve an XML external entity attack. Versions 1.9.4, 2.1.3, 2.3.2, and 3.4.0 fix the issue.
Weakness: CWE-611
Which versions are affected by CVE-2024-47873?
10 open source packages ship an affected version, including phpoffice/phpspreadsheet and phpoffice/phpexcel. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpoffice/phpspreadsheet Packagist | All versions | 1.29.4 |
phpoffice/phpspreadsheet Packagist | All versions | 1.29.4 |
phpoffice/phpspreadsheet Packagist | From 2.0.0 | 2.1.3 |
phpoffice/phpspreadsheet Packagist | From 2.0.0 | 2.1.3 |
phpoffice/phpspreadsheet Packagist | From 2.2.0 | 2.3.2 |
phpoffice/phpspreadsheet Packagist | From 2.2.0 | 2.3.2 |
4 more packages
phpoffice/phpspreadsheet Packagist | From 3.3.0 | 3.4.0 |
phpoffice/phpspreadsheet Packagist | From 3.3.0 | 3.4.0 |
phpoffice/phpexcel Packagist | All versions to 1.8.2 | None |
phpoffice/phpexcel Packagist | All versions to 1.8.2 | None |
Products include Phpoffice Phpspreadsheet.
How do I fix CVE-2024-47873?
Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.29.4, 2.1.3, 2.3.2 or 3.4.0.
Is CVE-2024-47873 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47873 exists.
Other vulnerabilities in PHPOffice PhpSpreadsheet
- CVE-2026-34084 PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load
- CVE-2024-45048 XML External Entity Reference (XXE) in PHPSpreadsheet
- CVE-2019-12331 XXE in PHPSpreadsheet due to incomplete fix for previous encoding issue
- CVE-2018-19277 XXE in PHPSpreadsheet due to encoding issue
- CVE-2024-56365 PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class
Sources
Also known as GHSA-jw4x-v69f-hh5w.