# CVE-2024-47873: PhpSpreadsheet XmlScanner bypass leads to XXE

> Attackers can bypass XML sanitization in PhpSpreadsheet to perform XML External Entity attacks, potentially reading sensitive data or executing code.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Nov 2024
- **Updated:** 18 Nov 2024
- **Also known as:** GHSA-jw4x-v69f-hh5w

## What is CVE-2024-47873?

CVE-2024-47873 is a high-severity vulnerability in PHPOffice PhpSpreadsheet, published on 18 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. The XmlScanner class has a scan method which should prevent XXE attacks. However, prior to versions 1.9.4, 2.1.3, 2.3.2, and 3.4.0, the regexes used in the `scan` method and the findCharSet method can be bypassed by using UCS-4 and encoding guessing. An attacker can bypass the sanitizer and achieve an XML external entity attack. Versions 1.9.4, 2.1.3, 2.3.2, and 3.4.0 fix the issue.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2024-47873?

10 open source packages ship an affected version, including phpoffice/phpspreadsheet and phpoffice/phpexcel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.29.4 |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.29.4 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.3 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.3 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.3.2 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.3.2 |
| `phpoffice/phpspreadsheet` | Packagist | From 3.3.0 | 3.4.0 |
| `phpoffice/phpspreadsheet` | Packagist | From 3.3.0 | 3.4.0 |
| `phpoffice/phpexcel` | Packagist | All versions to 1.8.2 | None |
| `phpoffice/phpexcel` | Packagist | All versions to 1.8.2 | None |

Products: Phpoffice Phpspreadsheet.

## How do I fix CVE-2024-47873?

Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.29.4, 2.1.3, 2.3.2 or 3.4.0.

## Is CVE-2024-47873 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47873 exists.

## Other vulnerabilities in PHPOffice PhpSpreadsheet

- [CVE-2026-34084](https://insights.sbomify.com/CVE-2026-34084/): PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load (critical 9.2)
- [CVE-2024-45048](https://insights.sbomify.com/CVE-2024-45048/): XML External Entity Reference (XXE) in PHPSpreadsheet (high 8.8)
- [CVE-2019-12331](https://insights.sbomify.com/CVE-2019-12331/): XXE in PHPSpreadsheet due to incomplete fix for previous encoding issue (high 8.8)
- [CVE-2018-19277](https://insights.sbomify.com/CVE-2018-19277/): XXE in PHPSpreadsheet due to encoding issue (high 8.8)
- [CVE-2024-56365](https://insights.sbomify.com/CVE-2024-56365/): PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47873 and fix it if it is affected.

What it is: CVE-2024-47873 is a high-severity vulnerability in PHPOffice PhpSpreadsheet, published on 18 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47873 exists.

Affected packages and fixed versions:
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.29.4
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.29.4
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.3
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.3
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.3.2
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.3.2
- phpoffice/phpspreadsheet (Packagist): affected from 3.3.0; fixed in 3.4.0
- phpoffice/phpspreadsheet (Packagist): affected from 3.3.0; fixed in 3.4.0
- phpoffice/phpexcel (Packagist): affected all versions up to 1.8.2; no fix listed
- phpoffice/phpexcel (Packagist): affected all versions up to 1.8.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47873/ (Markdown: https://insights.sbomify.com/CVE-2024-47873/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47873
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47873
- OSV: https://osv.dev/vulnerability/CVE-2024-47873

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47873/
Summaries are generated and may contain mistakes; the official description above is the record.
