# CVE-2024-47880: OpenRefine has a reflected cross-site scripting vulnerability from POST request in ExportRowsCommand

> Attackers can execute arbitrary JavaScript in victims' browsers via reflected XSS in OpenRefine, potentially leading to data theft or code execution.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Oct 2024
- **Updated:** 28 Oct 2024
- **Also known as:** DEBIAN-CVE-2024-47880, GHSA-79jv-5226-783f, UBUNTU-CVE-2024-47880

## What is CVE-2024-47880?

CVE-2024-47880 is a high-severity cross-site scripting vulnerability in OpenRefine, published on 24 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OpenRefine is a free, open source tool for working with messy data. Prior to version 3.8.3, the `export-rows` command can be used in such a way that it reflects part of the request verbatim, with a Content-Type header also taken from the request. An attacker could lead a user to a malicious page that submits a form POST that contains  embedded JavaScript code. This code would then be included in the response, along with an attacker-controlled `Content-Type` header, and so potentially executed in the victim's browser as if it was part of OpenRefine. The attacker-provided code can do anything the user can do, including deleting projects, retrieving database passwords, or executing arbitrary Jython or Closure expressions, if those extensions are also present. The attacker must know a valid project ID of a project that contains at least one row. Version 3.8.3 fixes the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-348 (Use of Less Trusted Source)

## Which versions are affected by CVE-2024-47880?

2 open source packages ship an affected version, including org.openrefine:openrefine. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.openrefine:openrefine` | Maven | All versions | 3.8.3 |
| `org.openrefine:openrefine` | Maven | All versions | 3.8.3 |

Products: Openrefine Openrefine.

## How do I fix CVE-2024-47880?

Upgrade org.openrefine:openrefine to 3.8.3 or later.

## Is CVE-2024-47880 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47880 exists.

## Other vulnerabilities in OpenRefine

- [CVE-2023-41887](https://insights.sbomify.com/CVE-2023-41887/): Remote Code exec in project import with mysql jdbc url attack (critical 9.8)
- [CVE-2024-47878](https://insights.sbomify.com/CVE-2024-47878/): Reflected cross-site scripting vulnerability (XSS) in GData extension (authorized.vt) (high 8.1)
- [CVE-2024-47881](https://insights.sbomify.com/CVE-2024-47881/): OpenRefine's SQLite integration allows filesystem access, remote code execution (RCE) (high 8.1)
- [CVE-2024-47879](https://insights.sbomify.com/CVE-2024-47879/): OpenRefine's PreviewExpressionCommand, which is eval, lacks protection against cross-site request forgery (CSRF) (high 7.6)
- [CVE-2024-23833](https://insights.sbomify.com/CVE-2024-23833/): OpenRefine JDBC Attack Vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47880 and fix it if it is affected.

What it is: CVE-2024-47880 is a high-severity cross-site scripting vulnerability in OpenRefine, published on 24 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47880 exists.

Affected packages and fixed versions:
- org.openrefine:openrefine (Maven): affected all versions; fixed in 3.8.3
- org.openrefine:openrefine (Maven): affected all versions; fixed in 3.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47880/ (Markdown: https://insights.sbomify.com/CVE-2024-47880/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47880
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47880
- OSV: https://osv.dev/vulnerability/CVE-2024-47880

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47880/
Summaries are generated and may contain mistakes; the official description above is the record.
