# CVE-2024-47882: OpenRefine's error page lacks escaping, leading to potential Cross-site Scripting on import of malicious project

> OpenRefine's error page fails to escape HTML, allowing attackers to inject scripts via malicious project imports, potentially leading to code execution.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Oct 2024
- **Updated:** 25 Oct 2024
- **Also known as:** DEBIAN-CVE-2024-47882, GHSA-j8hp-f2mj-586g, UBUNTU-CVE-2024-47882

## What is CVE-2024-47882?

CVE-2024-47882 is a medium-severity cross-site scripting vulnerability in OpenRefine, published on 24 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OpenRefine is a free, open source tool for working with messy data. Prior to version 3.8.3, the built-in "Something went wrong!" error page includes the exception message and exception traceback without escaping HTML tags, enabling injection into the page if an attacker can reliably produce an error with an attacker-influenced message. It appears that the only way to reach this code in OpenRefine itself is for an attacker to somehow convince a victim to import a malicious file, which may be difficult.  However, out-of-tree extensions may add their own calls to `respondWithErrorPage`. Version 3.8.3 has a fix for this issue.

Weakness: CWE-81 (Improper Neutralization of Script in an Error Message Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-47882?

2 open source packages ship an affected version, including org.openrefine:openrefine. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.openrefine:openrefine` | Maven | All versions | 3.8.3 |
| `org.openrefine:openrefine` | Maven | All versions | 3.8.3 |

Products: Openrefine Openrefine.

## How do I fix CVE-2024-47882?

Upgrade org.openrefine:openrefine to 3.8.3 or later.

## Is CVE-2024-47882 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47882 exists.

## Other vulnerabilities in OpenRefine

- [CVE-2023-41887](https://insights.sbomify.com/CVE-2023-41887/): Remote Code exec in project import with mysql jdbc url attack (critical 9.8)
- [CVE-2024-47878](https://insights.sbomify.com/CVE-2024-47878/): Reflected cross-site scripting vulnerability (XSS) in GData extension (authorized.vt) (high 8.1)
- [CVE-2024-47880](https://insights.sbomify.com/CVE-2024-47880/): OpenRefine has a reflected cross-site scripting vulnerability from POST request in ExportRowsCommand (high 8.1)
- [CVE-2024-47881](https://insights.sbomify.com/CVE-2024-47881/): OpenRefine's SQLite integration allows filesystem access, remote code execution (RCE) (high 8.1)
- [CVE-2024-47879](https://insights.sbomify.com/CVE-2024-47879/): OpenRefine's PreviewExpressionCommand, which is eval, lacks protection against cross-site request forgery (CSRF) (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47882 and fix it if it is affected.

What it is: CVE-2024-47882 is a medium-severity cross-site scripting vulnerability in OpenRefine, published on 24 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47882 exists.

Affected packages and fixed versions:
- org.openrefine:openrefine (Maven): affected all versions; fixed in 3.8.3
- org.openrefine:openrefine (Maven): affected all versions; fixed in 3.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47882/ (Markdown: https://insights.sbomify.com/CVE-2024-47882/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47882
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47882
- OSV: https://osv.dev/vulnerability/CVE-2024-47882

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47882/
Summaries are generated and may contain mistakes; the official description above is the record.
