{"answers":{"affected":"9 open source packages ship an affected version, including rails and actiontext.","exploited":"There is no known exploitation of CVE-2024-47888 in the wild and no public exploit code.","fix":"Upgrade rails to a fixed version for your release line: 6.1.8, 7.0.9, 7.1.4 or 7.2.2.","what":"CVE-2024-47888 is a medium-severity denial of service vulnerability in rails, published on 16 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-47888 and fix it if it is affected.\n\nWhat it is: CVE-2024-47888 is a medium-severity denial of service vulnerability in rails, published on 16 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-47888 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rails (Bitnami): affected from 6.0.0; fixed in 6.1.8, 7.0.9, 7.1.4, 7.2.2\n- actiontext (RubyGems): affected from 6.0.0; fixed in 6.1.7.9\n- actiontext (RubyGems): affected from 6.0.0; fixed in 6.1.7.9\n- actiontext (RubyGems): affected from 7.0.0; fixed in 7.0.8.5\n- actiontext (RubyGems): affected from 7.0.0; fixed in 7.0.8.5\n- actiontext (RubyGems): affected from 7.1.0; fixed in 7.1.4.1\n- actiontext (RubyGems): affected from 7.1.0; fixed in 7.1.4.1\n- actiontext (RubyGems): affected from 7.2.0; fixed in 7.2.1.1\n- actiontext (RubyGems): affected from 7.2.0; fixed in 7.2.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-47888/ (Markdown: https://insights.sbomify.com/CVE-2024-47888/index.md)","id":"CVE-2024-47888","markdown":"https://insights.sbomify.com/CVE-2024-47888/index.md","name":"CVE-2024-47888","record":{"aliases":["BIT-rails-2024-47888","DEBIAN-CVE-2024-47888","GHSA-wwhv-wxv9-rpgw","UBUNTU-CVE-2024-47888","openSUSE-SU-2024:14473-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rails Action Text","requires_auth":"none","summary":"Attackers can cause denial of service in Rails applications via crafted text triggering ReDoS in Action Text blockquote processing.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.6,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"Action Text brings rich text content and editing to Rails. Starting in version 6.0.0 and prior to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, and 7.2.1.1, there is a possible ReDoS vulnerability in the `plain_text_for_blockquote_node helper` in Action Text. Carefully crafted text can cause the `plain_text_for_blockquote_node` helper to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, or 7.2.1.1 or apply the relevant patch immediately. As a workaround, users can avoid calling `plain_text_for_blockquote_node` or upgrade to Ruby 3.2. Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 depends on Ruby 3.2 or greater so is unaffected.","ecosystems":["Bitnami","RubyGems","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Action Text has possible ReDoS vulnerability in plain_text_for_blockquote_node","id":"CVE-2024-47888","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":10,"n_references":5,"next":{"headline":"Action Mailer has possible ReDoS vulnerability in block_format","id":"CVE-2024-47889"},"packages":[{"ecosystem":"Bitnami","fixed":["6.1.8","7.0.9","7.1.4","7.2.2"],"introduced":["6.0.0","7.0.0","7.1.0","7.2.0"],"last_affected":[],"package":"rails","purl":"pkg:bitnami/rails","source":"BIT-rails-2024-47888"},{"ecosystem":"RubyGems","fixed":["6.1.7.9"],"introduced":["6.0.0"],"last_affected":[],"package":"actiontext","purl":null,"source":"GHSA-wwhv-wxv9-rpgw"},{"ecosystem":"RubyGems","fixed":["6.1.7.9"],"introduced":["6.0.0"],"last_affected":[],"package":"actiontext","purl":"pkg:gem/actiontext","source":"GHSA-wwhv-wxv9-rpgw"},{"ecosystem":"RubyGems","fixed":["7.0.8.5"],"introduced":["7.0.0"],"last_affected":[],"package":"actiontext","purl":null,"source":"GHSA-wwhv-wxv9-rpgw"},{"ecosystem":"RubyGems","fixed":["7.0.8.5"],"introduced":["7.0.0"],"last_affected":[],"package":"actiontext","purl":"pkg:gem/actiontext","source":"GHSA-wwhv-wxv9-rpgw"},{"ecosystem":"RubyGems","fixed":["7.1.4.1"],"introduced":["7.1.0"],"last_affected":[],"package":"actiontext","purl":null,"source":"GHSA-wwhv-wxv9-rpgw"},{"ecosystem":"RubyGems","fixed":["7.1.4.1"],"introduced":["7.1.0"],"last_affected":[],"package":"actiontext","purl":"pkg:gem/actiontext","source":"GHSA-wwhv-wxv9-rpgw"},{"ecosystem":"RubyGems","fixed":["7.2.1.1"],"introduced":["7.2.0"],"last_affected":[],"package":"actiontext","purl":null,"source":"GHSA-wwhv-wxv9-rpgw"},{"ecosystem":"RubyGems","fixed":["7.2.1.1"],"introduced":["7.2.0"],"last_affected":[],"package":"actiontext","purl":"pkg:gem/actiontext","source":"GHSA-wwhv-wxv9-rpgw"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["7.0.8.6-1.1"],"introduced":["0"],"last_affected":[],"package":"rubygem-actiontext-7.0","purl":"pkg:rpm/opensuse/rubygem-actiontext-7.0\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14473-1"}],"prev":{"headline":"Action Controller has possible ReDoS vulnerability in HTTP Token authentication","id":"CVE-2024-47887"},"products":["rails"],"published":"2024-10-16","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-16","vendors":["rails"]},"summary":"Attackers can cause denial of service in Rails applications via crafted text triggering ReDoS in Action Text blockquote processing.","url":"https://insights.sbomify.com/CVE-2024-47888/"}