CVE-2024-47913 Improper permissions handling in MediaWiki AbuseFilter
Unauthorized API callers can view AbuseFilter log details they are not permitted to access, leading to information disclosure.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-47913?
CVE-2024-47913 is a medium-severity vulnerability in Mediawiki Mediawiki, published on 4 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in the AbuseFilter extension for MediaWiki before 1.39.9, 1.40.x and 1.41.x before 1.41.3, and 1.42.x before 1.42.2. An API caller can match a filter condition against AbuseFilter logs even if the caller is not authorized to view the log details for the filter.
Weakness: CWE-532
Which versions are affected by CVE-2024-47913?
6 open source packages ship an affected version, including mediawiki/abuse-filter. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki/abuse-filter Packagist | All versions | 1.39.9 |
mediawiki/abuse-filter Packagist | All versions | 1.39.9 |
mediawiki/abuse-filter Packagist | From 1.40.0 | 1.41.3 |
mediawiki/abuse-filter Packagist | From 1.40.0 | 1.41.3 |
mediawiki/abuse-filter Packagist | From 1.42.0 | 1.42.2 |
mediawiki/abuse-filter Packagist | From 1.42.0 | 1.42.2 |
Products include Mediawiki Mediawiki.
How do I fix CVE-2024-47913?
Upgrade mediawiki/abuse-filter to a fixed version for your release line: 1.39.9, 1.41.3 or 1.42.2.
Is CVE-2024-47913 being exploited?
There is no known exploitation of CVE-2024-47913 in the wild and no public exploit code.
Other vulnerabilities in Mediawiki Mediawiki
Sources
Also known as DEBIAN-CVE-2024-47913, DSA-5785-1, GHSA-rmcp-9fhq-58pv, UBUNTU-CVE-2024-47913.