# CVE-2024-47913: Improper permissions handling in MediaWiki AbuseFilter

> Unauthorized API callers can view AbuseFilter log details they are not permitted to access, leading to information disclosure.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Oct 2024
- **Updated:** 6 Dec 2024
- **Also known as:** DEBIAN-CVE-2024-47913, DSA-5785-1, GHSA-rmcp-9fhq-58pv, UBUNTU-CVE-2024-47913

## What is CVE-2024-47913?

CVE-2024-47913 is a medium-severity vulnerability in Mediawiki Mediawiki, published on 4 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the AbuseFilter extension for MediaWiki before 1.39.9, 1.40.x and 1.41.x before 1.41.3, and 1.42.x before 1.42.2. An API caller can match a filter condition against AbuseFilter logs even if the caller is not authorized to view the log details for the filter.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2024-47913?

6 open source packages ship an affected version, including mediawiki/abuse-filter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki/abuse-filter` | Packagist | All versions | 1.39.9 |
| `mediawiki/abuse-filter` | Packagist | All versions | 1.39.9 |
| `mediawiki/abuse-filter` | Packagist | From 1.40.0 | 1.41.3 |
| `mediawiki/abuse-filter` | Packagist | From 1.40.0 | 1.41.3 |
| `mediawiki/abuse-filter` | Packagist | From 1.42.0 | 1.42.2 |
| `mediawiki/abuse-filter` | Packagist | From 1.42.0 | 1.42.2 |

Products: Mediawiki Mediawiki.

## How do I fix CVE-2024-47913?

Upgrade mediawiki/abuse-filter to a fixed version for your release line: 1.39.9, 1.41.3 or 1.42.2.

## Is CVE-2024-47913 being exploited?

There is no known exploitation of CVE-2024-47913 in the wild and no public exploit code.

## Other vulnerabilities in Mediawiki Mediawiki

- [CVE-2023-37303](https://insights.sbomify.com/CVE-2023-37303/): Denial of service in n/a (critical 9.8)
- [CVE-2022-29904](https://insights.sbomify.com/CVE-2022-29904/): SQL injection in n/a (critical 9.8)
- [CVE-2022-29906](https://insights.sbomify.com/CVE-2022-29906/): Missing authorization in n/a (critical 9.8)
- [CVE-2022-28205](https://insights.sbomify.com/CVE-2022-28205/): Business logic in n/a (critical 9.8)
- [CVE-2022-28206](https://insights.sbomify.com/CVE-2022-28206/): Missing authorization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47913 and fix it if it is affected.

What it is: CVE-2024-47913 is a medium-severity vulnerability in Mediawiki Mediawiki, published on 4 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-47913 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki/abuse-filter (Packagist): affected all versions; fixed in 1.39.9
- mediawiki/abuse-filter (Packagist): affected all versions; fixed in 1.39.9
- mediawiki/abuse-filter (Packagist): affected from 1.40.0; fixed in 1.41.3
- mediawiki/abuse-filter (Packagist): affected from 1.40.0; fixed in 1.41.3
- mediawiki/abuse-filter (Packagist): affected from 1.42.0; fixed in 1.42.2
- mediawiki/abuse-filter (Packagist): affected from 1.42.0; fixed in 1.42.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47913/ (Markdown: https://insights.sbomify.com/CVE-2024-47913/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47913
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47913
- OSV: https://osv.dev/vulnerability/CVE-2024-47913

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47913/
Summaries are generated and may contain mistakes; the official description above is the record.
