CVE-2024-48050 AgentScope uses `eval`
Attackers can execute arbitrary code via unsafe eval in workflow utilities, requiring an upgrade to the agentscope library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-48050?
CVE-2024-48050 is a critical code injection vulnerability in n/a, published on 4 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In agentscope <=v0.0.4, the file agentscope\web\workstation\workflow_utils.py has the function is_callable_expression. Within this function, the line result = eval(s) poses a security risk as it can directly execute user-provided commands.
Weakness: CWE-94
Which versions are affected by CVE-2024-48050?
3 open source packages ship an affected version, including agentscope. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
agentscope PyPI | All versions to 0.1.0 | None |
agentscope PyPI | All versions to 0.1.0 | None |
agentscope PyPI | All versions | 0.0.5a1 |
Products include Modelscope Agentscope.
How do I fix CVE-2024-48050?
Upgrade agentscope to 0.0.5a1 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2024-48050 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-48050 exists.
Other vulnerabilities in n/a
Sources
Also known as GHSA-6p55-qr3j-mpgq, PYSEC-2024-262.