{"answers":{"affected":"3 open source packages ship an affected version, including agentscope. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-48050 exists.","fix":"Upgrade agentscope to 0.0.5a1 or later.","what":"CVE-2024-48050 is a critical code injection vulnerability in n/a, published on 4 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-48050 and fix it if it is affected.\n\nWhat it is: CVE-2024-48050 is a critical code injection vulnerability in n/a, published on 4 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-48050 exists.\n\nAffected packages and fixed versions:\n- agentscope (PyPI): affected all versions up to 0.1.0; no fix listed\n- agentscope (PyPI): affected all versions up to 0.1.0; no fix listed\n- agentscope (PyPI): affected all versions; fixed in 0.0.5a1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-48050/ (Markdown: https://insights.sbomify.com/CVE-2024-48050/index.md)","id":"CVE-2024-48050","markdown":"https://insights.sbomify.com/CVE-2024-48050/index.md","name":"CVE-2024-48050","record":{"aliases":["GHSA-6p55-qr3j-mpgq","PYSEC-2024-262"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python AI agent library","requires_auth":"none","summary":"Attackers can execute arbitrary code via unsafe eval in workflow utilities, requiring an upgrade to the agentscope library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"agentscope","vendor":"modelscope"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"In agentscope \u003c=v0.0.4, the file agentscope\\web\\workstation\\workflow_utils.py has the function is_callable_expression. Within this function, the line result = eval(s) poses a security risk as it can directly execute user-provided commands.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"AgentScope uses `eval`","id":"CVE-2024-48050","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"gradio Server Side Request Forgery vulnerability","id":"CVE-2024-48052"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["0.1.0"],"package":"agentscope","purl":null,"source":"GHSA-6p55-qr3j-mpgq"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["0.1.0"],"package":"agentscope","purl":"pkg:pypi/agentscope","source":"GHSA-6p55-qr3j-mpgq"},{"ecosystem":"PyPI","fixed":["0.0.5a1"],"introduced":["0"],"last_affected":[],"package":"agentscope","purl":"pkg:pypi/agentscope","source":"PYSEC-2024-262"}],"prev":{"headline":"WordPress Mighty Builder plugin \u003c= 1.0.2 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-48049"},"products":["n/a"],"published":"2024-11-04","related":[{"cvss_score":9.1,"headline":"Path Traversal in modelscope/agentscope","id":"CVE-2024-8537","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.1,"headline":"Path Traversal in modelscope/agentscope","id":"CVE-2024-8551","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":7.5,"headline":"Path Traversal in modelscope/agentscope","id":"CVE-2024-8438","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":7.5,"headline":"Arbitrary File Download in modelscope/agentscope","id":"CVE-2024-8501","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":7.5,"headline":"Directory Traversal in modelscope/agentscope","id":"CVE-2024-8524","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":7.5,"headline":"Local File Inclusion (LFI) in modelscope/agentscope","id":"CVE-2024-8550","kev_date_added":null,"published":"2025-02-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-11-06","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via unsafe eval in workflow utilities, requiring an upgrade to the agentscope library.","url":"https://insights.sbomify.com/CVE-2024-48050/"}