{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-48208 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2024-48208 is a high-severity memory corruption vulnerability in n/a, published on 24 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-48208 and fix it if it is affected.\n\nWhat it is: CVE-2024-48208 is a high-severity memory corruption vulnerability in n/a, published on 24 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-48208 exists.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-48208/ (Markdown: https://insights.sbomify.com/CVE-2024-48208/index.md)","id":"CVE-2024-48208","markdown":"https://insights.sbomify.com/CVE-2024-48208/index.md","name":"CVE-2024-48208","record":{"aliases":["DEBIAN-CVE-2024-48208","GHSA-rrmj-qxgv-v296","UBUNTU-CVE-2024-48208","openSUSE-SU-2025:15266-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"FTP server","requires_auth":"none","summary":"An out-of-bounds read in pure-ftpd's ls.c file can lead to buffer overflow, potentially causing denial of service or code execution.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pure-ftpd","vendor":"pureftpd"}],"cvss":{"score":8.6,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"pure-ftpd before 1.0.52 is vulnerable to Buffer Overflow. There is an out of bounds read in the domlsd() function of the ls.c file.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":"2024-10-30","github_poc":1,"max_poc_stars":7,"metasploit":0,"nuclei":1,"refs":[{"date":"2024-10-30T01:44:32Z","kind":"github_poc","ref":"https://github.com/rohilchaudhry/CVE-2024-48208","stars":7,"title":"This repo contains all the work surrounding the development of the PoC for CVE-2024-48208, and how a simple OOB(Out-of-bound) read can result in jail escapes as well as broken access control."},{"date":null,"kind":"nuclei","ref":"network/cves/2024/CVE-2024-48208.yaml","stars":null,"title":"Pure-FTPd \u003c 1.0.52 - Buffer Overflow"}],"tier":"weaponised"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2024-48208","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2024"},"n_packages":1,"n_references":1,"next":{"headline":"Path traversal in n/a","id":"CVE-2024-48213"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.0.51-5.1"],"introduced":["0"],"last_affected":[],"package":"pure-ftpd","purl":"pkg:rpm/opensuse/pure-ftpd\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15266-1"}],"prev":{"headline":"Deserialization in n/a","id":"CVE-2024-48206"},"products":["n/a"],"published":"2024-10-24","related":[{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2021-40524","kev_date_added":null,"published":"2021-09-05"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2020-35359","kev_date_added":null,"published":"2020-12-26"},{"cvss_score":5.8,"headline":"Other in n/a","id":"CVE-2011-1575","kev_date_added":null,"published":"2011-05-23"},{"cvss_score":3.6,"headline":"Path traversal in n/a","id":"CVE-2011-3171","kev_date_added":null,"published":"2011-11-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-28","vendors":["n/a"]},"summary":"An out-of-bounds read in pure-ftpd's ls.c file can lead to buffer overflow, potentially causing denial of service or code execution.","url":"https://insights.sbomify.com/CVE-2024-48208/"}