CVE-2024-4835 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

High 8.0 Published Updated

An attacker can exploit a cross-site scripting vulnerability in GitLab to exfiltrate sensitive user information via a malicious page.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-4835?

CVE-2024-4835 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 23 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A XSS condition exists within GitLab in versions 15.11 before 16.10.6, 16.11 before 16.11.3, and 17.0 before 17.0.1. By leveraging this condition, an attacker can craft a malicious page to exfiltrate sensitive user information.

Weakness: CWE-79

Which versions are affected by CVE-2024-4835?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.11.016.10.6, 16.11.3, 17.0.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-4835?

Upgrade gitlab to a fixed version for your release line: 16.10.6, 16.11.3 or 17.0.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-4835 being exploited?

There is no known exploitation of CVE-2024-4835 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-4835, GHSA-9r4p-g7c7-2c4r, UBUNTU-CVE-2024-4835.

Is CVE-2024-4835 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free