{"answers":{"affected":"2 open source packages ship an affected version, including tabby-ssh.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-48460 exists.","fix":"Upgrade tabby-ssh to 1.0.214 or later.","what":"CVE-2024-48460 is a medium-severity vulnerability in n/a, published on 16 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-48460 and fix it if it is affected.\n\nWhat it is: CVE-2024-48460 is a medium-severity vulnerability in n/a, published on 16 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-48460 exists.\n\nAffected packages and fixed versions:\n- tabby-ssh (npm): affected all versions; fixed in 1.0.214\n- tabby-ssh (npm): affected all versions; fixed in 1.0.214\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-48460/ (Markdown: https://insights.sbomify.com/CVE-2024-48460/index.md)","id":"CVE-2024-48460","markdown":"https://insights.sbomify.com/CVE-2024-48460/index.md","name":"CVE-2024-48460","record":{"aliases":["GHSA-8vq4-8hfp-29xh"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Tabby terminal emulator","requires_auth":"none","summary":"Remote attackers can obtain sensitive SSH credentials when host key verification fails in the Tabby terminal emulator.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":4.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"An issue in Eugeny Tabby 1.0.213 allows a remote attacker to obtain sensitive information via the server and sends the SSH username and password even when the host key verification fails.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Eugeny Tabby Sends Password Despite Host Key Verification Failure","id":"CVE-2024-48460","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2024-48461"},"packages":[{"ecosystem":"npm","fixed":["1.0.214"],"introduced":["0"],"last_affected":[],"package":"tabby-ssh","purl":null,"source":"GHSA-8vq4-8hfp-29xh"},{"ecosystem":"npm","fixed":["1.0.214"],"introduced":["0"],"last_affected":[],"package":"tabby-ssh","purl":"pkg:npm/tabby-ssh","source":"GHSA-8vq4-8hfp-29xh"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2024-48459"},"products":["n/a"],"published":"2025-01-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-03","vendors":["n/a"]},"summary":"Remote attackers can obtain sensitive SSH credentials when host key verification fails in the Tabby terminal emulator.","url":"https://insights.sbomify.com/CVE-2024-48460/"}