# CVE-2024-48460: Eugeny Tabby Sends Password Despite Host Key Verification Failure

> Remote attackers can obtain sensitive SSH credentials when host key verification fails in the Tabby terminal emulator.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Jan 2025
- **Updated:** 3 Feb 2025
- **Also known as:** GHSA-8vq4-8hfp-29xh

## What is CVE-2024-48460?

CVE-2024-48460 is a medium-severity vulnerability in n/a, published on 16 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue in Eugeny Tabby 1.0.213 allows a remote attacker to obtain sensitive information via the server and sends the SSH username and password even when the host key verification fails.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2024-48460?

2 open source packages ship an affected version, including tabby-ssh.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tabby-ssh` | npm | All versions | 1.0.214 |
| `tabby-ssh` | npm | All versions | 1.0.214 |

## How do I fix CVE-2024-48460?

Upgrade tabby-ssh to 1.0.214 or later.

## Is CVE-2024-48460 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-48460 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-48460 and fix it if it is affected.

What it is: CVE-2024-48460 is a medium-severity vulnerability in n/a, published on 16 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-48460 exists.

Affected packages and fixed versions:
- tabby-ssh (npm): affected all versions; fixed in 1.0.214
- tabby-ssh (npm): affected all versions; fixed in 1.0.214

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-48460/ (Markdown: https://insights.sbomify.com/CVE-2024-48460/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-48460
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-48460
- OSV: https://osv.dev/vulnerability/CVE-2024-48460

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-48460/
Summaries are generated and may contain mistakes; the official description above is the record.
