{"answers":{"affected":"4 open source packages ship an affected version, including DotNetZip and ProDotNetZip. It affects 2 products.","exploited":"There is no known exploitation of CVE-2024-48510 in the wild and no public exploit code.","fix":"Product is end of life, replace it.","what":"CVE-2024-48510 is a critical path traversal vulnerability in n/a, published on 13 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-48510 and fix it if it is affected.\n\nWhat it is: CVE-2024-48510 is a critical path traversal vulnerability in n/a, published on 13 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-48510 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- DotNetZip (NuGet): affected from 1.10.1 up to 1.16.0; no fix listed\n- DotNetZip (NuGet): affected from 1.10.1 up to 1.16.0; no fix listed\n- ProDotNetZip (NuGet): affected all versions; fixed in 1.19.0\n- ProDotNetZip (NuGet): affected all versions; fixed in 1.19.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-48510/ (Markdown: https://insights.sbomify.com/CVE-2024-48510/index.md)","id":"CVE-2024-48510","markdown":"https://insights.sbomify.com/CVE-2024-48510/index.md","name":"CVE-2024-48510","record":{"aliases":["GHSA-xhg6-9j5j-w4vf"],"analysis":{"component_type":"library","fix_type":"end_of_life","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"DotNetZip library","requires_auth":"none","summary":"A remote attacker can execute arbitrary code via a directory traversal flaw in the unsupported DotNetZip library.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"dotnetzip.semverd","vendor":"dotnetzip.semverd_project"},{"product":"prodotnetzip","vendor":"mihula"}],"cvss":{"score":9.1,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Directory Traversal vulnerability in DotNetZip v.1.16.0 and before allows a remote attacker to execute arbitrary code via the src/Zip.Shared/ZipEntry.Extract.cs component NOTE: This vulnerability only affects products that are no longer supported by the maintainer.","ecosystems":["NuGet"],"exploits":{"exploitdb":0,"first_seen":"2026-03-19","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-03-19T18:17:24Z","kind":"github_poc","ref":"https://github.com/havertz2110/CVE-2024-48510-PoC","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"DotNetZip Directory Traversal vulnerability","id":"CVE-2024-48510","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":4,"n_references":4,"next":{"headline":"Remote code execution in php-heic-to-jpg","id":"CVE-2024-48514"},"packages":[{"ecosystem":"NuGet","fixed":[],"introduced":["1.10.1"],"last_affected":["1.16.0"],"package":"DotNetZip","purl":null,"source":"GHSA-xhg6-9j5j-w4vf"},{"ecosystem":"NuGet","fixed":[],"introduced":["1.10.1"],"last_affected":["1.16.0"],"package":"DotNetZip","purl":"pkg:nuget/DotNetZip","source":"GHSA-xhg6-9j5j-w4vf"},{"ecosystem":"NuGet","fixed":["1.19.0"],"introduced":["0"],"last_affected":[],"package":"ProDotNetZip","purl":null,"source":"GHSA-xhg6-9j5j-w4vf"},{"ecosystem":"NuGet","fixed":["1.19.0"],"introduced":["0"],"last_affected":[],"package":"ProDotNetZip","purl":"pkg:nuget/ProDotNetZip","source":"GHSA-xhg6-9j5j-w4vf"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2024-48509"},"products":["n/a"],"published":"2024-11-13","related":[{"cvss_score":5.5,"headline":"DotNetZip Zip-Slip Vulnerability","id":"CVE-2018-1002205","kev_date_added":null,"published":"2018-07-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-11-21","vendors":["n/a"]},"summary":"A remote attacker can execute arbitrary code via a directory traversal flaw in the unsupported DotNetZip library.","url":"https://insights.sbomify.com/CVE-2024-48510/"}