# CVE-2024-48510: DotNetZip Directory Traversal vulnerability

> A remote attacker can execute arbitrary code via a directory traversal flaw in the unsupported DotNetZip library.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Nov 2024
- **Updated:** 21 Nov 2024
- **Also known as:** GHSA-xhg6-9j5j-w4vf

## What is CVE-2024-48510?

CVE-2024-48510 is a critical path traversal vulnerability in n/a, published on 13 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directory Traversal vulnerability in DotNetZip v.1.16.0 and before allows a remote attacker to execute arbitrary code via the src/Zip.Shared/ZipEntry.Extract.cs component NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-48510?

4 open source packages ship an affected version, including DotNetZip and ProDotNetZip. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `DotNetZip` | NuGet | From 1.10.1 to 1.16.0 | None |
| `DotNetZip` | NuGet | From 1.10.1 to 1.16.0 | None |
| `ProDotNetZip` | NuGet | All versions | 1.19.0 |
| `ProDotNetZip` | NuGet | All versions | 1.19.0 |

Products: Dotnetzip.semverd Project Dotnetzip.semverd, Mihula Prodotnetzip.

## How do I fix CVE-2024-48510?

Product is end of life, replace it.

## Is CVE-2024-48510 being exploited?

There is no known exploitation of CVE-2024-48510 in the wild and no public exploit code.

Public exploit code:

- https://github.com/havertz2110/CVE-2024-48510-PoC (github_poc): https://github.com/havertz2110/CVE-2024-48510-PoC

## Other vulnerabilities in n/a

- [CVE-2018-1002205](https://insights.sbomify.com/CVE-2018-1002205/): DotNetZip Zip-Slip Vulnerability (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-48510 and fix it if it is affected.

What it is: CVE-2024-48510 is a critical path traversal vulnerability in n/a, published on 13 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-48510 in the wild and no public exploit code.

Affected packages and fixed versions:
- DotNetZip (NuGet): affected from 1.10.1 up to 1.16.0; no fix listed
- DotNetZip (NuGet): affected from 1.10.1 up to 1.16.0; no fix listed
- ProDotNetZip (NuGet): affected all versions; fixed in 1.19.0
- ProDotNetZip (NuGet): affected all versions; fixed in 1.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-48510/ (Markdown: https://insights.sbomify.com/CVE-2024-48510/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-48510
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-48510
- OSV: https://osv.dev/vulnerability/CVE-2024-48510

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-48510/
Summaries are generated and may contain mistakes; the official description above is the record.
