CVE-2024-48514 Remote code execution in php-heic-to-jpg

Critical 9.8 Published Updated

An attacker can execute arbitrary code on the server by uploading a malicious HEIC image with a crafted filename.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-48514?

CVE-2024-48514 is a critical code injection vulnerability in n/a, published on 24 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

php-heic-to-jpg <= 1.0.5 is vulnerable to code injection (fixed in 1.0.6). An attacker who can upload heic images is able to execute code on the remote server via the file name. As a result, the CIA is no longer guaranteed. This affects php-heic-to-jpg 1.0.5 and below.

Weakness: CWE-94

Which versions are affected by CVE-2024-48514?

2 open source packages ship an affected version, including maestroerror/php-heic-to-jpg.

PackageAffectedFixed in
maestroerror/php-heic-to-jpg PackagistAll versions1.0.5
maestroerror/php-heic-to-jpg PackagistAll versions1.0.5

How do I fix CVE-2024-48514?

Upgrade maestroerror/php-heic-to-jpg to 1.0.5 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2024-48514 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-48514 exists.

Sources

Also known as GHSA-g8v9-c8m3-942v.

Is CVE-2024-48514 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free