# CVE-2024-48514: Remote code execution in php-heic-to-jpg

> An attacker can execute arbitrary code on the server by uploading a malicious HEIC image with a crafted filename.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Oct 2024
- **Updated:** 19 Dec 2024
- **Also known as:** GHSA-g8v9-c8m3-942v

## What is CVE-2024-48514?

CVE-2024-48514 is a critical code injection vulnerability in n/a, published on 24 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

php-heic-to-jpg <= 1.0.5 is vulnerable to code injection (fixed in 1.0.6). An attacker who can upload heic images is able to execute code on the remote server via the file name. As a result, the CIA is no longer guaranteed. This affects php-heic-to-jpg 1.0.5 and below.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-48514?

2 open source packages ship an affected version, including maestroerror/php-heic-to-jpg.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `maestroerror/php-heic-to-jpg` | Packagist | All versions | 1.0.5 |
| `maestroerror/php-heic-to-jpg` | Packagist | All versions | 1.0.5 |

## How do I fix CVE-2024-48514?

Upgrade maestroerror/php-heic-to-jpg to 1.0.5 or later.

## Is CVE-2024-48514 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-48514 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-48514 and fix it if it is affected.

What it is: CVE-2024-48514 is a critical code injection vulnerability in n/a, published on 24 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-48514 exists.

Affected packages and fixed versions:
- maestroerror/php-heic-to-jpg (Packagist): affected all versions; fixed in 1.0.5
- maestroerror/php-heic-to-jpg (Packagist): affected all versions; fixed in 1.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-48514/ (Markdown: https://insights.sbomify.com/CVE-2024-48514/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-48514
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-48514
- OSV: https://osv.dev/vulnerability/CVE-2024-48514

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-48514/
Summaries are generated and may contain mistakes; the official description above is the record.
