# CVE-2024-4860: Cross-site scripting in rebelcode:rss aggregator

> An attacker can execute arbitrary scripts in the victim's browser via the unsanitized notice_id parameter in the WordPress RSS Aggregator plugin.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 14 May 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-p7q5-4hfm-m8fh

## What is CVE-2024-4860?

CVE-2024-4860 is a medium-severity cross-site scripting vulnerability in rebelcode:rss_aggregator, published on 14 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The 'WordPress RSS Aggregator' WordPress Plugin, versions < 4.23.9 are affected by a Cross-Site Scripting (XSS) vulnerability due to the lack of sanitization of the  'notice_id'  GET parameter.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-4860?

It affects 1 product.


Products: Rebelcode Rss Aggregator.

## How do I fix CVE-2024-4860?

No fix has been published for CVE-2024-4860 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-4860 being exploited?

There is no known exploitation of CVE-2024-4860 in the wild and no public exploit code.

## Other vulnerabilities in rebelcode:rss_aggregator

- [CVE-2024-9583](https://insights.sbomify.com/CVE-2024-9583/): RSS Aggregator – RSS Import, News Feeds, Feed to Post, and Autoblogging <= 4.23.12 - Missing Authorization (medium 4.3)
- [CVE-2024-6621](https://insights.sbomify.com/CVE-2024-6621/): WP RSS Aggregator <= 4.23.11 - Missing Authorization to Authenticated (Subscriber+) Feed State Update (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-4860 and fix it if it is affected.

What it is: CVE-2024-4860 is a medium-severity cross-site scripting vulnerability in rebelcode:rss_aggregator, published on 14 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-4860 in the wild and no public exploit code.

Affected product: rebelcode:rss_aggregator. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-4860/ (Markdown: https://insights.sbomify.com/CVE-2024-4860/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-4860
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-4860
- OSV: https://osv.dev/vulnerability/CVE-2024-4860

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-4860/
Summaries are generated and may contain mistakes; the official description above is the record.
