CVE-2024-48872 Bypass of "Max failed attempts" restriction via race condition
Attackers can bypass login attempt limits by exploiting a race condition, enabling brute-force attacks against user accounts.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-48872?
CVE-2024-48872 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 16 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Mattermost versions 10.1.x <= 10.1.2, 10.0.x <= 10.0.2, 9.11.x <= 9.11.4, and 9.5.x <= 9.5.12 fail to prevent concurrently checking and updating the failed login attempts. which allows an attacker to bypass of "Max failed attempts" restriction and send a big number of login attempts before being blocked via simultaneously sending multiple login requests
Weakness: CWE-362
Which versions are affected by CVE-2024-48872?
12 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | From 10.0.0 | 10.0.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.0.0 | 10.0.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.1.0 | 10.1.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.1.0 | 10.1.3 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.5 |
6 more packages
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.5 |
github.com/mattermost/mattermost/server/v8 Go | From 9.5.0 | 9.5.13 |
github.com/mattermost/mattermost/server/v8 Go | From 9.5.0 | 9.5.13 |
github.com/mattermost/mattermost-server Go | From 9.5.0+incompatible | 9.5.13+incompatible, 9.11.5+incompatible, 10.0.3+incompatible, 10.1.3+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2024-48872?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 10.0.3, 10.1.3, 9.11.5 or 9.5.13.
Is CVE-2024-48872 being exploited?
There is no known exploitation of CVE-2024-48872 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-826h-p4c3-477p, GO-2024-3338.