# CVE-2024-4888: Arbitrary File Deletion in BerriAI/litellm

> Attackers can delete arbitrary server files via path traversal in the audio transcription endpoint, potentially compromising system integrity.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2024
- **Updated:** 3 Nov 2024
- **Also known as:** GHSA-3xr8-qfvj-9p9j, PYSEC-2026-1540

## What is CVE-2024-4888?

CVE-2024-4888 is a medium-severity path traversal vulnerability in berriai/litellm, published on 6 Jun 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

BerriAI's litellm, in its latest version, is vulnerable to arbitrary file deletion due to improper input validation on the `/audio/transcriptions` endpoint. An attacker can exploit this vulnerability by sending a specially crafted request that includes a file path to the server, which then deletes the specified file without proper authorization or validation. This vulnerability is present in the code where `os.remove(file.filename)` is used to delete a file, allowing any user to delete critical files on the server such as SSH keys, SQLite databases, or configuration files.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-4888?

3 open source packages ship an affected version, including litellm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | All versions | 1.35.36 |
| `litellm` | PyPI | All versions | 1.35.36 |
| `litellm` | PyPI | All versions | 1.35.36 |

Products: Litellm Litellm.

## How do I fix CVE-2024-4888?

Upgrade litellm to 1.35.36 or later.

## Is CVE-2024-4888 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4888 exists.

## Other vulnerabilities in berriai/litellm

- [CVE-2026-42208](https://insights.sbomify.com/CVE-2026-42208/): BerriAI LiteLLM SQL Injection (critical 9.3, exploited in the wild)
- [CVE-2026-59822](https://insights.sbomify.com/CVE-2026-59822/): BerriAI LiteLLM Improper Authentication (high 8.8, exploited in the wild)
- [CVE-2026-42271](https://insights.sbomify.com/CVE-2026-42271/): BerriAI LiteLLM Command Injection (high 8.7, exploited in the wild)
- [CVE-2024-5751](https://insights.sbomify.com/CVE-2024-5751/): Remote Code Execution in BerriAI/litellm (critical 9.8)
- [CVE-2024-2952](https://insights.sbomify.com/CVE-2024-2952/): Server-Side Template Injection in BerriAI/litellm (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-4888 and fix it if it is affected.

What it is: CVE-2024-4888 is a medium-severity path traversal vulnerability in berriai/litellm, published on 6 Jun 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4888 exists.

Affected packages and fixed versions:
- litellm (PyPI): affected all versions; fixed in 1.35.36
- litellm (PyPI): affected all versions; fixed in 1.35.36
- litellm (PyPI): affected all versions; fixed in 1.35.36

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-4888/ (Markdown: https://insights.sbomify.com/CVE-2024-4888/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-4888
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-4888
- OSV: https://osv.dev/vulnerability/CVE-2024-4888

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-4888/
Summaries are generated and may contain mistakes; the official description above is the record.
