CVE-2024-48897 Moodle: idor in edit/delete rss feed
Attackers can edit or delete RSS feeds belonging to other users due to missing permission checks in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-48897?
CVE-2024-48897 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 18 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A vulnerability was found in Moodle. Additional checks are required to ensure users can only edit or delete RSS feeds that they have permission to modify.
Which versions are affected by CVE-2024-48897?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.14 |
moodle/moodle Packagist | All versions | 4.1.14 |
moodle/moodle Packagist | From 4.2.0 | 4.2.11 |
moodle/moodle Packagist | From 4.2.0 | 4.2.11 |
moodle/moodle Packagist | From 4.3.0 | 4.3.8 |
moodle/moodle Packagist | From 4.3.0 | 4.3.8 |
3 more packages
moodle/moodle Packagist | From 4.4.0 | 4.4.4 |
moodle/moodle Packagist | From 4.4.0 | 4.4.4 |
moodle Bitnami | All versions | 4.1.19, 4.4.9 |
Products include Moodle Moodle.
How do I fix CVE-2024-48897?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.14, 4.2.11, 4.3.8 or 4.4.4.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-48897 being exploited?
There is no known exploitation of CVE-2024-48897 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2024-48897, GHSA-x3x9-349x-2485, UBUNTU-CVE-2024-48897.