{"answers":{"affected":"1 open source package ship an affected version, including lycheeverse/lychee-action.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-48908 exists.","fix":"Upgrade lycheeverse/lychee-action to 2.0.2 or later.","what":"CVE-2024-48908 is a medium-severity code injection vulnerability in lycheeverse lychee-action, published on 28 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-48908 and fix it if it is affected.\n\nWhat it is: CVE-2024-48908 is a medium-severity code injection vulnerability in lycheeverse lychee-action, published on 28 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-48908 exists.\n\nAffected packages and fixed versions:\n- lycheeverse/lychee-action (GitHub Actions): affected all versions; fixed in 2.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-48908/ (Markdown: https://insights.sbomify.com/CVE-2024-48908/index.md)","id":"CVE-2024-48908","markdown":"https://insights.sbomify.com/CVE-2024-48908/index.md","name":"CVE-2024-48908","record":{"aliases":["GHSA-65rg-554r-9j5x"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"GitHub Actions","requires_auth":"none","summary":"Attackers can inject arbitrary code via the lychee-setup composite action, allowing execution within the CI/CD environment.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"lychee link checking action checks links in Markdown, HTML, and text files using lychee. Prior to version 2.0.2, there is a potential attack of arbitrary code injection vulnerability in lychee-setup of the composite action at action.yml. This issue has been patched in version 2.0.2.","ecosystems":["GitHub Actions"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"lychee-action vulnerable to arbitrary code injection in composite action","id":"CVE-2024-48908","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"GitHub Actions","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":1,"n_references":2,"next":{"headline":"SpiceDB calls to LookupResources using LookupResources2 with caveats may return context is missing when it is not","id":"CVE-2024-48909"},"packages":[{"ecosystem":"GitHub Actions","fixed":["2.0.2"],"introduced":["0"],"last_affected":[],"package":"lycheeverse/lychee-action","purl":null,"source":"GHSA-65rg-554r-9j5x"}],"prev":{"headline":"Server-side request forgery in n/a","id":"CVE-2024-48907"},"products":["lychee-action"],"published":"2025-08-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-08-28","vendors":["lycheeverse"]},"summary":"Attackers can inject arbitrary code via the lychee-setup composite action, allowing execution within the CI/CD environment.","url":"https://insights.sbomify.com/CVE-2024-48908/"}