# CVE-2024-48909: SpiceDB calls to LookupResources using LookupResources2 with caveats may return context is missing when it is not

> SpiceDB may incorrectly report missing context for conditional permissions, potentially leading to incorrect authorization decisions.

- **Severity:** Low 2.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Oct 2024
- **Updated:** 15 Oct 2024
- **Also known as:** GHSA-3c32-4hq9-6wgj, GO-2024-3200

## What is CVE-2024-48909?

CVE-2024-48909 is a low-severity vulnerability in authzed spicedb, published on 14 Oct 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

SpiceDB is an open source database for scalably storing and querying fine-grained authorization data. Starting in version 1.35.0 and prior to version 1.37.1, clients that have enabled `LookupResources2` and have caveats in the evaluation path for their requests can return a permissionship of `CONDITIONAL` with context marked as missing, even then the context was supplied. LookupResources2 is the new default in SpiceDB 1.37.0 and has been opt-in since SpiceDB 1.35.0. The bug is patched as part of SpiceDB 1.37.1. As a workaround, disable LookupResources2 via the `--enable-experimental-lookup-resources` flag by setting it to `false`.

Weakness: CWE-172 (Improper Encoding or Decoding of Data)

## Which versions are affected by CVE-2024-48909?

3 open source packages ship an affected version, including github.com/authzed/spicedb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/authzed/spicedb` | Go | From 1.35.0 | 1.37.1 |
| `github.com/authzed/spicedb` | Go | From 1.35.0 | 1.37.1 |
| `github.com/authzed/spicedb` | Go | From 1.35.0 | 1.37.1 |

Products: Authzed Spicedb.

## How do I fix CVE-2024-48909?

Upgrade github.com/authzed/spicedb to 1.37.1 or later.

## Is CVE-2024-48909 being exploited?

There is no known exploitation of CVE-2024-48909 in the wild and no public exploit code.

## Other vulnerabilities in authzed spicedb

- [CVE-2023-29193](https://insights.sbomify.com/CVE-2023-29193/): SpiceDB binding metrics port to untrusted networks and can leak command-line flags (high 8.7)
- [CVE-2022-21646](https://insights.sbomify.com/CVE-2022-21646/): Lookup operations do not take into account wildcards in SpiceDB (high 8.1)
- [CVE-2024-27101](https://insights.sbomify.com/CVE-2024-27101/): Integer overflow in chunking helper causes dispatching to miss elements or panic (high 7.3)
- [CVE-2026-40091](https://insights.sbomify.com/CVE-2026-40091/): SpiceDB: SPICEDB_DATASTORE_CONN_URI is leaked on startup logs (medium 6.0)
- [CVE-2023-46255](https://insights.sbomify.com/CVE-2023-46255/): `SPICEDB_DATASTORE_CONN_URI` is leaked when URI cannot be parsed (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-48909 and fix it if it is affected.

What it is: CVE-2024-48909 is a low-severity vulnerability in authzed spicedb, published on 14 Oct 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-48909 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/authzed/spicedb (Go): affected from 1.35.0; fixed in 1.37.1
- github.com/authzed/spicedb (Go): affected from 1.35.0; fixed in 1.37.1
- github.com/authzed/spicedb (Go): affected from 1.35.0; fixed in 1.37.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-48909/ (Markdown: https://insights.sbomify.com/CVE-2024-48909/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-48909
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-48909
- OSV: https://osv.dev/vulnerability/CVE-2024-48909

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-48909/
Summaries are generated and may contain mistakes; the official description above is the record.
