CVE-2024-48911 OpenCanary Executes Commands From Potentially Writable Config File

Medium 5.8 Published Updated

An unprivileged user can escalate privileges to root by modifying the OpenCanary configuration file, which is executed by the root daemon.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2024-48911?

CVE-2024-48911 is a medium-severity vulnerability in thinkst opencanary, published on 14 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

OpenCanary, a multi-protocol network honeypot, directly executed commands taken from its config file. Prior to version 0.9.4, where the config file is stored in an unprivileged user directory but the daemon is executed by root, it’s possible for the unprivileged user to change the config file and escalate permissions when root later runs the daemon. Version 0.9.4 contains a fix for the issue.

Weakness: CWE-863

Which versions are affected by CVE-2024-48911?

3 open source packages ship an affected version, including opencanary and OpenCanary. It affects 1 product.

PackageAffectedFixed in
opencanary PyPIAll versions0.9.4
opencanary PyPIAll versions0.9.5
OpenCanary PyPIAll versions0.9.5

Products include Thinkst Opencanary.

How do I fix CVE-2024-48911?

Upgrade opencanary to a fixed version for your release line: 0.9.4 or 0.9.5.

Is CVE-2024-48911 being exploited?

There is no known exploitation of CVE-2024-48911 in the wild and no public exploit code.

Sources

Also known as GHSA-pf5v-pqfv-x8jj, PYSEC-2024-248.

Is CVE-2024-48911 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free