{"answers":{"affected":"3 open source packages ship an affected version, including opencanary and OpenCanary. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-48911 in the wild and no public exploit code.","fix":"Upgrade opencanary to a fixed version for your release line: 0.9.4 or 0.9.5.","what":"CVE-2024-48911 is a medium-severity vulnerability in thinkst opencanary, published on 14 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-48911 and fix it if it is affected.\n\nWhat it is: CVE-2024-48911 is a medium-severity vulnerability in thinkst opencanary, published on 14 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-48911 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- opencanary (PyPI): affected all versions; fixed in 0.9.4\n- opencanary (PyPI): affected all versions; fixed in 0.9.5\n- OpenCanary (PyPI): affected all versions; fixed in 0.9.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-48911/ (Markdown: https://insights.sbomify.com/CVE-2024-48911/index.md)","id":"CVE-2024-48911","markdown":"https://insights.sbomify.com/CVE-2024-48911/index.md","name":"CVE-2024-48911","record":{"aliases":["GHSA-pf5v-pqfv-x8jj","PYSEC-2024-248"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Network honeypot","requires_auth":"low_privilege","summary":"An unprivileged user can escalate privileges to root by modifying the OpenCanary configuration file, which is executed by the root daemon.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"opencanary","vendor":"thinkst"}],"cvss":{"score":5.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"OpenCanary, a multi-protocol network honeypot, directly executed commands taken from its config file. Prior to version 0.9.4, where the config file is stored in an unprivileged user directory but the daemon is executed by root, it’s possible for the unprivileged user to change the config file and escalate permissions when root later runs the daemon. Version 0.9.4 contains a fix for the issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenCanary Executes Commands From Potentially Writable Config File","id":"CVE-2024-48911","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"privilege_escalation","year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"GLPI vulnerable to authenticated insecure account deletion","id":"CVE-2024-48912"},"packages":[{"ecosystem":"PyPI","fixed":["0.9.5"],"introduced":["0"],"last_affected":[],"package":"OpenCanary","purl":null,"source":"GHSA-pf5v-pqfv-x8jj"},{"ecosystem":"PyPI","fixed":["0.9.4"],"introduced":["0"],"last_affected":[],"package":"opencanary","purl":"pkg:pypi/opencanary","source":"PYSEC-2024-248"},{"ecosystem":"PyPI","fixed":["0.9.5"],"introduced":["0"],"last_affected":[],"package":"opencanary","purl":"pkg:pypi/opencanary","source":"GHSA-pf5v-pqfv-x8jj"}],"prev":{"headline":"DOMPurify vulnerable to tampering by prototype polution","id":"CVE-2024-48910"},"products":["opencanary"],"published":"2024-10-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-15","vendors":["thinkst"]},"summary":"An unprivileged user can escalate privileges to root by modifying the OpenCanary configuration file, which is executed by the root daemon.","url":"https://insights.sbomify.com/CVE-2024-48911/"}