# CVE-2024-48911: OpenCanary Executes Commands From Potentially Writable Config File

> An unprivileged user can escalate privileges to root by modifying the OpenCanary configuration file, which is executed by the root daemon.

- **Severity:** Medium 5.8 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2024
- **Updated:** 15 Oct 2024
- **Also known as:** GHSA-pf5v-pqfv-x8jj, PYSEC-2024-248

## What is CVE-2024-48911?

CVE-2024-48911 is a medium-severity vulnerability in thinkst opencanary, published on 14 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

OpenCanary, a multi-protocol network honeypot, directly executed commands taken from its config file. Prior to version 0.9.4, where the config file is stored in an unprivileged user directory but the daemon is executed by root, it’s possible for the unprivileged user to change the config file and escalate permissions when root later runs the daemon. Version 0.9.4 contains a fix for the issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-48911?

3 open source packages ship an affected version, including opencanary and OpenCanary. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opencanary` | PyPI | All versions | 0.9.4 |
| `opencanary` | PyPI | All versions | 0.9.5 |
| `OpenCanary` | PyPI | All versions | 0.9.5 |

Products: Thinkst Opencanary.

## How do I fix CVE-2024-48911?

Upgrade opencanary to a fixed version for your release line: 0.9.4 or 0.9.5.

## Is CVE-2024-48911 being exploited?

There is no known exploitation of CVE-2024-48911 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-48911 and fix it if it is affected.

What it is: CVE-2024-48911 is a medium-severity vulnerability in thinkst opencanary, published on 14 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-48911 in the wild and no public exploit code.

Affected packages and fixed versions:
- opencanary (PyPI): affected all versions; fixed in 0.9.4
- opencanary (PyPI): affected all versions; fixed in 0.9.5
- OpenCanary (PyPI): affected all versions; fixed in 0.9.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-48911/ (Markdown: https://insights.sbomify.com/CVE-2024-48911/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-48911
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-48911
- OSV: https://osv.dev/vulnerability/CVE-2024-48911

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-48911/
Summaries are generated and may contain mistakes; the official description above is the record.
