{"answers":{"affected":"4 open source packages ship an affected version, including @vendure/asset-server-plugin.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-48914 exists.","fix":"Upgrade @vendure/asset-server-plugin to a fixed version for your release line: 2.3.3 or 3.0.5.","what":"CVE-2024-48914 is a critical path traversal vulnerability in vendure-ecommerce vendure, published on 15 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-48914 and fix it if it is affected.\n\nWhat it is: CVE-2024-48914 is a critical path traversal vulnerability in vendure-ecommerce vendure, published on 15 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-48914 exists.\n\nAffected packages and fixed versions:\n- @vendure/asset-server-plugin (npm): affected all versions; fixed in 2.3.3\n- @vendure/asset-server-plugin (npm): affected all versions; fixed in 2.3.3\n- @vendure/asset-server-plugin (npm): affected from 3.0.0; fixed in 3.0.5\n- @vendure/asset-server-plugin (npm): affected from 3.0.0; fixed in 3.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-48914/ (Markdown: https://insights.sbomify.com/CVE-2024-48914/index.md)","id":"CVE-2024-48914","markdown":"https://insights.sbomify.com/CVE-2024-48914/index.md","name":"CVE-2024-48914","record":{"aliases":["GHSA-r9mq-3c9r-fmjq"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Vendure commerce platform","requires_auth":"none","summary":"Attackers can traverse the file system to read sensitive files or crash the server via malformed URIs in the Vendure asset server plugin.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Vendure is an open-source headless commerce platform. Prior to versions 3.0.5 and 2.3.3, a vulnerability in Vendure's asset server plugin allows an attacker to craft a request which is able to traverse the server file system and retrieve the contents of arbitrary files, including sensitive data such as configuration files, environment variables, and other critical data stored on the server. In the same code path is an additional vector for crashing the server via a malformed URI. Patches are available in versions 3.0.5 and 2.3.3. Some workarounds are also available. One may use object storage rather than the local file system, e.g. MinIO or S3, or define middleware which detects and blocks requests with urls containing `/../`.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2024-10-21","github_poc":1,"max_poc_stars":5,"metasploit":0,"nuclei":1,"refs":[{"date":"2024-10-21T10:02:05Z","kind":"github_poc","ref":"https://github.com/EQSTLab/CVE-2024-48914","stars":5,"title":"Arbitrary File Read and DoS in vendure-ecommerce exploit"},{"date":null,"kind":"nuclei","ref":"http/cves/2024/CVE-2024-48914.yaml","stars":null,"title":"Vendure - Arbitrary File Read"}],"tier":"weaponised"},"has_fix":true,"headline":"Vendure asset server plugin has local file read vulnerability with AssetServerPlugin \u0026 LocalAssetStorageStrategy","id":"CVE-2024-48914","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":4,"n_references":4,"next":{"headline":"Agent Dart missing certificate verification checks","id":"CVE-2024-48915"},"packages":[{"ecosystem":"npm","fixed":["2.3.3"],"introduced":["0"],"last_affected":[],"package":"@vendure/asset-server-plugin","purl":null,"source":"GHSA-r9mq-3c9r-fmjq"},{"ecosystem":"npm","fixed":["2.3.3"],"introduced":["0"],"last_affected":[],"package":"@vendure/asset-server-plugin","purl":"pkg:npm/%40vendure/asset-server-plugin","source":"GHSA-r9mq-3c9r-fmjq"},{"ecosystem":"npm","fixed":["3.0.5"],"introduced":["3.0.0"],"last_affected":[],"package":"@vendure/asset-server-plugin","purl":null,"source":"GHSA-r9mq-3c9r-fmjq"},{"ecosystem":"npm","fixed":["3.0.5"],"introduced":["3.0.0"],"last_affected":[],"package":"@vendure/asset-server-plugin","purl":"pkg:npm/%40vendure/asset-server-plugin","source":"GHSA-r9mq-3c9r-fmjq"}],"prev":{"headline":"Hono vulnerable to bypass of CSRF Middleware by a request without Content-Type header.","id":"CVE-2024-48913"},"products":["vendure"],"published":"2024-10-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-15","vendors":["vendure-ecommerce"]},"summary":"Attackers can traverse the file system to read sensitive files or crash the server via malformed URIs in the Vendure asset server plugin.","url":"https://insights.sbomify.com/CVE-2024-48914/"}