{"answers":{"affected":"2 open source packages ship an affected version, including agent_dart.","exploited":"There is no known exploitation of CVE-2024-48915 in the wild and no public exploit code.","fix":"Upgrade agent_dart to 1.0.0-dev.29 or later.","what":"CVE-2024-48915 is a high-severity vulnerability in AstroxNetwork agent_dart, published on 15 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-48915 and fix it if it is affected.\n\nWhat it is: CVE-2024-48915 is a high-severity vulnerability in AstroxNetwork agent_dart, published on 15 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-48915 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- agent_dart (Pub): affected all versions; fixed in 1.0.0-dev.29\n- agent_dart (Pub): affected all versions; fixed in 1.0.0-dev.29\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-48915/ (Markdown: https://insights.sbomify.com/CVE-2024-48915/index.md)","id":"CVE-2024-48915","markdown":"https://insights.sbomify.com/CVE-2024-48915/index.md","name":"CVE-2024-48915","record":{"aliases":["GHSA-fmj7-7gfw-64pg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Dart agent library","requires_auth":"none","summary":"Missing certificate verification in Agent Dart allows subnets to impersonate others and bypass expiration, requiring an upgrade to secure Internet Computer interactions.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"Agent Dart is an agent library built for Internet Computer for Dart and Flutter apps. Prior to version 1.0.0-dev.29, certificate verification in `lib/agent/certificate.dart` does not occur properly. During the delegation verification in the `_checkDelegation` function, the canister_ranges aren't verified. The impact of not checking the canister_ranges is that a subnet can sign canister responses in behalf of another subnet. The certificate’s timestamp, i.e /time path, is also not verified, meaning that the certificate effectively has no expiration time. Version 1.0.0-dev.29 implements appropriate certificate verification.","ecosystems":["Pub"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Agent Dart missing certificate verification checks","id":"CVE-2024-48915","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"security_feature_bypass","year":"2024"},"n_packages":2,"n_references":4,"next":{"headline":"Ceph is vulnerable to authentication bypass through RadosGW","id":"CVE-2024-48916"},"packages":[{"ecosystem":"Pub","fixed":["1.0.0-dev.29"],"introduced":["0"],"last_affected":[],"package":"agent_dart","purl":null,"source":"GHSA-fmj7-7gfw-64pg"},{"ecosystem":"Pub","fixed":["1.0.0-dev.29"],"introduced":["0"],"last_affected":[],"package":"agent_dart","purl":"pkg:pub/agent_dart","source":"GHSA-fmj7-7gfw-64pg"}],"prev":{"headline":"Vendure asset server plugin has local file read vulnerability with AssetServerPlugin \u0026 LocalAssetStorageStrategy","id":"CVE-2024-48914"},"products":["agent_dart"],"published":"2024-10-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-21","vendors":["AstroxNetwork"]},"summary":"Missing certificate verification in Agent Dart allows subnets to impersonate others and bypass expiration, requiring an upgrade to secure Internet Computer interactions.","url":"https://insights.sbomify.com/CVE-2024-48915/"}