# CVE-2024-48915: Agent Dart missing certificate verification checks

> Missing certificate verification in Agent Dart allows subnets to impersonate others and bypass expiration, requiring an upgrade to secure Internet Computer interactions.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Oct 2024
- **Updated:** 21 Nov 2024
- **Also known as:** GHSA-fmj7-7gfw-64pg

## What is CVE-2024-48915?

CVE-2024-48915 is a high-severity vulnerability in AstroxNetwork agent_dart, published on 15 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Agent Dart is an agent library built for Internet Computer for Dart and Flutter apps. Prior to version 1.0.0-dev.29, certificate verification in `lib/agent/certificate.dart` does not occur properly. During the delegation verification in the `_checkDelegation` function, the canister_ranges aren't verified. The impact of not checking the canister_ranges is that a subnet can sign canister responses in behalf of another subnet. The certificate’s timestamp, i.e /time path, is also not verified, meaning that the certificate effectively has no expiration time. Version 1.0.0-dev.29 implements appropriate certificate verification.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2024-48915?

2 open source packages ship an affected version, including agent_dart.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `agent_dart` | Pub | All versions | 1.0.0-dev.29 |
| `agent_dart` | Pub | All versions | 1.0.0-dev.29 |

## How do I fix CVE-2024-48915?

Upgrade agent_dart to 1.0.0-dev.29 or later.

## Is CVE-2024-48915 being exploited?

There is no known exploitation of CVE-2024-48915 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-48915 and fix it if it is affected.

What it is: CVE-2024-48915 is a high-severity vulnerability in AstroxNetwork agent_dart, published on 15 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-48915 in the wild and no public exploit code.

Affected packages and fixed versions:
- agent_dart (Pub): affected all versions; fixed in 1.0.0-dev.29
- agent_dart (Pub): affected all versions; fixed in 1.0.0-dev.29

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-48915/ (Markdown: https://insights.sbomify.com/CVE-2024-48915/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-48915
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-48915
- OSV: https://osv.dev/vulnerability/CVE-2024-48915

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-48915/
Summaries are generated and may contain mistakes; the official description above is the record.
