# CVE-2024-48921: Kyverno's PolicyException objects can be created in any namespace by default

> Users with namespace privileges can bypass cluster security policies by creating PolicyExceptions in unauthorized namespaces.


- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Oct 2024
- **Updated:** 29 Oct 2024
- **Also known as:** BIT-kyverno-2024-48921, CLEANSTART-2026-KC89812, CLEANSTART-2026-VX56698, GHSA-qjvc-p88j-j9rm, GO-2024-3230, MINI-385p-crgg-h7hw, MINI-9cvj-jm8r-v2jx, MINI-hm3j-6p2q-cp44, MINI-q4f4-9g74-22jg, MINI-r3gx-654v-4wfp

## What is CVE-2024-48921?

CVE-2024-48921 is a high-severity missing authorization vulnerability in kyverno, published on 29 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Kyverno is a policy engine designed for Kubernetes. A kyverno ClusterPolicy, ie. "disallow-privileged-containers," can be overridden by the creation of a PolicyException in a random namespace. By design, PolicyExceptions are consumed from any namespace. Administrators may not recognize that this allows users with privileges to non-kyverno namespaces to create exceptions. This vulnerability is fixed in 1.13.0.

Weakness: CWE-863 (Incorrect Authorization), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2024-48921?

4 open source packages ship an affected version, including github.com/kyverno/kyverno and kyverno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kyverno/kyverno` | Go | All versions | 1.13.0 |
| `github.com/kyverno/kyverno` | Go | All versions | 1.13.0 |
| `github.com/kyverno/kyverno` | Go | All versions | 1.13.0 |
| `kyverno` | Bitnami | All versions | 1.13.0 |

Products: Nirmata Kyverno.

## How do I fix CVE-2024-48921?

Upgrade github.com/kyverno/kyverno to 1.13.0 or later.

## Is CVE-2024-48921 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-48921 exists.

## Other vulnerabilities in kyverno

- [CVE-2023-34091](https://insights.sbomify.com/CVE-2023-34091/): Kyverno resource with a deletionTimestamp may allow policy circumvention (medium 6.5)
- [CVE-2023-42813](https://insights.sbomify.com/CVE-2023-42813/): Denial of service from malicious manifest in kyverno (medium 6.1)
- [CVE-2023-42816](https://insights.sbomify.com/CVE-2023-42816/): Denial of service from malicious signature in kyverno (medium 6.1)
- [CVE-2023-33191](https://insights.sbomify.com/CVE-2023-33191/): kyverno seccomp control can be circumvented (medium 4.6)
- [CVE-2023-42814](https://insights.sbomify.com/CVE-2023-42814/): Denial of service from malicious image manifest in kyverno (low 3.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-48921 and fix it if it is affected.

What it is: CVE-2024-48921 is a high-severity missing authorization vulnerability in kyverno, published on 29 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-48921 exists.

Affected packages and fixed versions:
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.13.0
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.13.0
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.13.0
- kyverno (Bitnami): affected all versions; fixed in 1.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-48921/ (Markdown: https://insights.sbomify.com/CVE-2024-48921/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-48921
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-48921
- OSV: https://osv.dev/vulnerability/CVE-2024-48921

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-48921/
Summaries are generated and may contain mistakes; the official description above is the record.
