CVE-2024-48944 Apache Kylin: SSRF vulnerability in the diagnosis api
An attacker with admin access can exploit SSRF in Apache Kylin to access internal hosts and potentially leak sensitive information.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-48944?
CVE-2024-48944 is a medium-severity server-side request forgery vulnerability in Apache Kylin, published on 27 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin. Through a kylin server, an attacker may forge a request to invoke "/kylin/api/xxx/diag" api on another internal host and possibly get leaked information. There are two preconditions: 1) The attacker has got admin access to a kylin server; 2) Another internal host has the "/kylin/api/xxx/diag" api
endpoint open for service.
This issue affects Apache Kylin: from 5.0.0 through
5.0.1.
Users are recommended to upgrade to version 5.0.2, which fixes the issue.
Weakness: CWE-918
Which versions are affected by CVE-2024-48944?
2 open source packages ship an affected version, including org.apache.kylin:kylin-common-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.kylin:kylin-common-server Maven | From 5.0.0 | 5.0.2 |
org.apache.kylin:kylin-common-server Maven | From 5.0.0 | 5.0.2 |
Products include Apache Kylin.
How do I fix CVE-2024-48944?
Upgrade org.apache.kylin:kylin-common-server to 5.0.2 or later.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2024-48944 being exploited?
There is no known exploitation of CVE-2024-48944 in the wild and no public exploit code.
Other vulnerabilities in Apache Kylin
- CVE-2020-1956 Apache Kylin OS Command Injection
- CVE-2026-62390 Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API
- CVE-2022-44621 Apache Kylin: Command injection by Diagnosis Controller
- CVE-2022-24697 Apache Kylin vulnerable to remote code execution
- CVE-2021-31522 Apache Kylin unsafe class loading
Sources
Also known as GHSA-3v67-545x-ffc3.