{"answers":{"affected":"2 open source packages ship an affected version, including elliptic. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-48948 exists.","fix":"Upgrade elliptic to 6.6.0 or later.","what":"CVE-2024-48948 is a medium-severity vulnerability in n/a, published on 15 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-48948 and fix it if it is affected.\n\nWhat it is: CVE-2024-48948 is a medium-severity vulnerability in n/a, published on 15 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-48948 exists.\n\nAffected packages and fixed versions:\n- elliptic (npm): affected all versions; fixed in 6.6.0\n- elliptic (npm): affected all versions; fixed in 6.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-48948/ (Markdown: https://insights.sbomify.com/CVE-2024-48948/index.md)","id":"CVE-2024-48948","markdown":"https://insights.sbomify.com/CVE-2024-48948/index.md","name":"CVE-2024-48948","record":{"aliases":["DEBIAN-CVE-2024-48948","GHSA-fc9h-whq2-v747","ROOT-APP-NPM-CVE-2024-48948","UBUNTU-CVE-2024-48948","openSUSE-SU-2024:14433-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js ECDSA library","requires_auth":"none","summary":"Attackers can cause denial of service by triggering signature verification failures in the Elliptic Node.js library due to a truncation anomaly.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"elliptic","vendor":"indutny"}],"cvss":{"score":4.8,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"The Elliptic package 6.5.7 for Node.js, in its for ECDSA implementation, does not correctly verify valid signatures if the hash contains at least four leading 0 bytes and when the order of the elliptic curve's base point is smaller than the hash, because of an _truncateToN anomaly. This leads to valid signatures being rejected. Legitimate transactions or communications may be incorrectly flagged as invalid.","ecosystems":["npm","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Valid ECDSA signatures erroneously rejected in Elliptic","id":"CVE-2024-48948","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"Elliptic's verify function omits uniqueness validation","id":"CVE-2024-48949"},"packages":[{"ecosystem":"npm","fixed":["6.6.0"],"introduced":["0"],"last_affected":[],"package":"elliptic","purl":null,"source":"GHSA-fc9h-whq2-v747"},{"ecosystem":"npm","fixed":["6.6.0"],"introduced":["0"],"last_affected":[],"package":"elliptic","purl":"pkg:npm/elliptic","source":"GHSA-fc9h-whq2-v747"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["4.1.1-3.1"],"introduced":["0"],"last_affected":[],"package":"python-pytest-html","purl":"pkg:rpm/opensuse/python-pytest-html\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14433-1"}],"prev":{"headline":"Apache Kylin: SSRF vulnerability in the diagnosis api","id":"CVE-2024-48944"},"products":["n/a"],"published":"2024-10-15","related":[{"cvss_score":9.1,"headline":"Elliptic's verify function omits uniqueness validation","id":"CVE-2024-48949","kev_date_added":null,"published":"2024-10-10"},{"cvss_score":7.7,"headline":"Signature Malleabillity in elliptic","id":"CVE-2020-13822","kev_date_added":null,"published":"2020-06-04"},{"cvss_score":6.8,"headline":"Cryptographic Issues","id":"CVE-2020-28498","kev_date_added":null,"published":"2021-02-02"},{"cvss_score":5.3,"headline":"Elliptic's EDDSA missing signature length check","id":"CVE-2024-42459","kev_date_added":null,"published":"2024-08-02"},{"cvss_score":5.3,"headline":"Elliptic's ECDSA missing check for whether leading bit of r and s is zero","id":"CVE-2024-42460","kev_date_added":null,"published":"2024-08-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-25","vendors":["n/a"]},"summary":"Attackers can cause denial of service by triggering signature verification failures in the Elliptic Node.js library due to a truncation anomaly.","url":"https://insights.sbomify.com/CVE-2024-48948/"}